Diesel Place banner
Status
Not open for further replies.
1 - 15 of 15 Posts

·
Registered
Joined
·
1,411 Posts
Discussion Starter · #1 ·
this is the second time this has happened. my exhaust came loose at the 4-5 in adapter. the first time i manages to get it back in and i tightened the **** out of the band clamp, didn't think it would happen again but it did. now that it has, im thinkin about tackin it once i get it back in place. my buddys got a TIG that wouldn't work that well since the pipes aluminized but my uncles got a MIG that would probably be ok. i was thinkin id lay one or two 1 inch beads on it and just be done with it. what do yall think?
 

·
Registered
Joined
·
24 Posts
thats all you have to do bud,i have done a butt load of them that same way,that should cure all your problems
 

·
Registered
Joined
·
10,030 Posts
I just run a stainless self tapping screw into each joint to avoid this and if the tail pipe wanted to roll over time. Didnt want to tig it if I want to remove later and put on a new truck in the future. Easily heatup the joints and pull apart.

Brian
 

·
Registered
Joined
·
1,411 Posts
Discussion Starter · #5 ·
if i did lay a bead on it, i could just grind the bead down if i wanted to take the pipe off right?
 

·
Registered
Joined
·
10,030 Posts
be no problem grinding down later. Just be sure you have the tools to get in there or plan to buy something to do the job later on.

Brian
 

·
Registered
Joined
·
1,411 Posts
Discussion Starter · #7 ·
someone told me if i welded id need to weld all the way around the pipe or it would leak.. this true?

i was also told that if the band clamp was tightened properly id have no problem with slipping. ill try to hit it with an impact wrench next wknd before i try to weld it
 

·
Registered
Joined
·
1,913 Posts
My 4 in. mbrp was doing that when I first put it on. After I loosened all the joints and rotated everything so it hung more naturally and took the stress off it, I re-tightened everything and it's been good since. I like the new mbrp band clamps but the ones attached to the hangars could fit better. Mine was actually spinning at the hangar/band clamp on the front of the muffler. The joint was wide enough to add a second band clamp there and it has not moved since. Are you saying it came all the way apart ? That seems like it would be pretty hard to do. I don't see if you have a cc or ec. I know the ec install requires cutting one pipe to the correct length,are you sure you didn't cut it too short ? The only thing I tack welded was the tip to keep it from walking away in a parking lot somewhere.
 

·
Registered
Joined
·
1,411 Posts
Discussion Starter · #9 ·
mines a crew cab short bed. i did no cutting and heres a pic:


 

·
Banned
Joined
·
2,194 Posts
get a stainless steel band clamp from napa or somthing, those u-bolt clamps suck, I've never had a problem with mine, I bought the napa clamps to replace all the MBRP provided clamps, no leaks or anything either. There only like $7-9 a piece and should fix your problems.
 

·
Registered
Joined
·
1,913 Posts
Yes ditto on the band clamps, they are much better. With an 07 I assumed you had the newer setup with the band clamps.I thought all the new mbrp kits had the band clamps but maybe they still use the u bolts on the aluminized steel kits, or you got an older kit from stock.
 

·
Banned
Joined
·
2,194 Posts
Yes ditto on the band clamps, they are much better. With an 07 I assumed you had the newer setup with the band clamps.I thought all the new mbrp kits had the band clamps but maybe they still use the u bolts on the aluminized steel kits, or you got an older kit from stock.
They changed to the band clamps for like a month or two and are back to the u-bolts, I bought mine right after they changed back.
 

·
Registered
Joined
·
1,411 Posts
Discussion Starter · #13 ·
ill try that out. yall think oreillys or vato zone would have them?
 

·
Registered
Joined
·
1,913 Posts
They changed to the band clamps for like a month or two and are back to the u-bolts, I bought mine right after they changed back.
I'd be surprised if that were true. That's a step backward. I know when I bought mine they only had the band clamps with the stainless systems and the aluminized steel systems still had the u-bolts. I know a Mbrp rep used to hang out here maybe he will chime in and set us straight on whats going on.
 

·
Registered
Joined
·
1,913 Posts
ill try that out. yall think oreillys or vato zone would have them?
I think you could get the band clamps at most better quality auto parts stores like napa locally.
 
1 - 15 of 15 Posts
Status
Not open for further replies.
Top