Diesel Place banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9,300 Posts
Discussion Starter #1
Not by the dealer but by me. I started rocking the truck from the rear side to side. It started making a croaking/bumping noise. I had the service tech crawl underneath the car and feel around till he found it. It was the front plastic pad on leaf spring 2 right side. It was chafing and making a god awefull thumping sound that resonated through the whole rear of the truck. I told them I would grease it and they said it needed to be replaced. No time or parts to do it now. Will get it done by a more competent dealer when I get home from my trip to WY.

I did get the H2 takeoffs installed today. They are rubbing on the rear of the fender well plastic. I will try to heat/bend it tommorrow as I ran out of daylight today. One tiny drip leak at the oilguard return line by the pan to fix as well. Then all I need to do is run a constant hot wire to my xm radio so it stays on while im starting the car (really irratating).

My friend hates the H2 takeoffs he's short and cant get into the truck now :)

Its quite a bit taller and you can tell its geared taller now too. It shifts into 5th and Im doing about 85mph.
 

·
Registered
Joined
·
1,005 Posts
Good to hear the other shoe fall ~ be sure to get back w/us upon your return and let us know how the knockoffs worked out.
 

·
Registered
Joined
·
9,300 Posts
Discussion Starter #3
I fixed it. I jacked the truck up by the rear end. I then pounded a flat tip screw driver in between the leafs. I then used a popsicle stick to rub axle grease between the leaf pads at the front end of the leafs.

Shes a quiet as a virgin now...
Thank God I was going nuts from the excessive pounding noise...
 
1 - 3 of 3 Posts
Top