Diesel Place banner

1 - 20 of 27 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I was driving along about 40mph when my 04.5 lly just died. I was running the edge with attitude on level 3/1 and had been driving for 20 min so the engine was at normal operating temp. The codes, according to the stealership, were for the injector pump. They reset the codes, but didn't fix anything because it didn't do it while they had it. My question is has anyone else had this kind of trouble. I've had it in for injector pump twice, injectors twice, and a leaking turbo tube twice, all within a year and a half.
 

·
Registered
Joined
·
569 Posts
edge killed my lb7 quite a few times, just shut off while driving. no codes were thrown however.. you can call edge and theylll send you a new unit
 

·
Registered
Joined
·
294 Posts
I've left mine stock too, have had no issues pulling a 12K horse trailer.

Besides, I have a M/C to mod, The HP/Weight is a lot better :D
 

·
Registered
Joined
·
1,721 Posts
Also keep an eye on the edge modual location under the hood. If it gets too hot, it will freak out on you. I had to relocate mine to a cooler area and no problemo.
 

·
Registered
Joined
·
490 Posts
edge killed my lb7 quite a few times, just shut off while driving. no codes were thrown however.. you can call edge and theylll send you a new unit
Ditto
 

·
Registered
Joined
·
23 Posts
I don't know if my problem is the same as yours, I was doing about 70 mph, not hauling anything down a freeway, everything seem to be fine? no. my Dmax all at once sounded like a dodge com. truck. lost power big time, thought I sucked a valve, towed it to dealer, had it for 6 days and they said it was the "Stack" something to do with the injector wire harness timing.
 

·
Registered
Joined
·
54 Posts
IMHO...Edge Products are JUNK!!! Look at all the "bad Edge" posts on this website alone!?!
I've had my Bully Dog power pup on my truck for about 4 weeks and about 6500 miles with absolutely NO problems! I've got it set at 50 h.p. and pull 25,000 lb loads all day long up and down 17 mile grades with no heating problems whatsoever.
However, time will tell this summer when ground temps start getting 130* plus!
 

·
Registered
Joined
·
569 Posts
Ehhh...
id pick edge over BD anyday. :shrug: thats just me. they may have a few problems but they are isolated and the company does teh best
 

·
Registered
Joined
·
42 Posts
I had the same type of problems,either shutting down or running on 7 cylinders,I got rid of my Edge and have hadno problems since. I thought it was a waste of money anyway,and I would rather spend the money on making my truck look good from now on.
 

·
Registered
Joined
·
2,149 Posts
Id take Banks over edge anyday. Banks be doing business for along time.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #12
The weird thing is two weeks prior to this my truck wouldn't start. I primed the pump and it was fine. I'm not even sure the edge had anything to do with it.
 

·
Registered
Joined
·
2,641 Posts
I know from what ever-body says, they run better with all the aftermarket junk, but I'm keeping mine bone stock! :rant:
:exactly:
 

·
Registered
Joined
·
2,149 Posts
The weird thing is two weeks prior to this my truck wouldn't start. I primed the pump and it was fine. I'm not even sure the edge had anything to do with it.
Im pretty sure that had nothing to do with EDGE. maybe you have a fuel leak somewhere.
 

·
Registered
Joined
·
412 Posts
The Edge made my tires wear out fast and ruined my bumpers! Yeah right! :confused: Holy crap, Batman......All programmers, chips and mods have their ups and downs. It's up to you to figure it out and make it work!

At least do a search on the Edge/Attitude and read the pros and cons and ACTUAL REAL EMPERICAL INFORMATION before spouting all your negative anecdotal "it ruined my dvd player" type crap. A LOT of members here are running Edge products just fine, and the EDGE PRODUCTS company have costomer service and free replacement policies (when there really IS a problem) second to none.

Sorry for my harshness but I'm so sick of these negative email frenzies happening to good products. Seems to happen to Edge a lot by people desparately looking for someone to blame their problems on! :rant:
 

·
Registered
Joined
·
412 Posts
I know from what ever-body says, they run better with all the aftermarket junk, but I'm keeping mine bone stock! :rant:
Great..See you back at the starting line with your clogged intake and high EGT's....You probably don't even need to read most of the stuff here if you have your mind set on "bone stock". I would keep a little more of an open mind! ):h
 

·
Premium Member
Joined
·
554 Posts
IMHO...Edge Products are JUNK!!! Look at all the "bad Edge" posts on this website alone!?!
I've had my Bully Dog power pup on my truck for about 4 weeks and about 6500 miles with absolutely NO problems! I've got it set at 50 h.p. and pull 25,000 lb loads all day long up and down 17 mile grades with no heating problems whatsoever.
However, time will tell this summer when ground temps start getting 130* plus!
Obviously you haven't seen all the BD posts. You are definitely in the minority.
 

·
Premium Member
Joined
·
554 Posts

·
Registered
Joined
·
88 Posts
this is my secound duramax and my secound duramax with the edge and I have had zero problems with either.... except for stacking but that is another issuse...... I had 175k on my first edge truck
 
1 - 20 of 27 Posts
Top