Diesel Place banner
1 - 12 of 12 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
I just received my edge evolution. A few questions.

1. Should I update it before installing it?

2. Can I program it to level 2 and unplug it, and will the program stay?

3. The book says 35HP on level 2 for LBZ and edge website says 60HPfor LBZ on level 2? Torque is the same.

Any help will be appreciated.

Thanks
 

·
Registered
Joined
·
380 Posts
1. Yes, definately update. The tunes have got a lot more refined. Although I think Level 3 used to have a lot more power as it used to smoke constantly and now it only lets out a puff.

2. Yes, you do not need to have the programmer in the truck. It is just nice to have around to use as a gauge. You need to have an EGT gauge to monitor with the evolution. It runs pretty hot right now until they evolve the tunes a little more. They still haven't touched the boost tables yet.

3. I think the HP and Torque levels are changing a bit as they refine their tunes. I know Level 3 was a bit more of an animal than it is now. Level 2 actually feels slightly stronger than before and Level 1 is a bit milder right now to try to make it a real economy tune. I am not seeing any improvements on mileage or only slight increases. I am going to go back to Level 2 for a while until I see some more improvements in mileage.
 

·
Registered
Joined
·
1,257 Posts
Coghlin;1620081; said:
1. Yes, definately update. The tunes have got a lot more refined. Although I think Level 3 used to have a lot more power as it used to smoke constantly and now it only lets out a puff.

2. Yes, you do not need to have the programmer in the truck. It is just nice to have around to use as a gauge. You need to have an EGT gauge to monitor with the evolution. It runs pretty hot right now until they evolve the tunes a little more. They still haven't touched the boost tables yet.

3. I think the HP and Torque levels are changing a bit as they refine their tunes. I know Level 3 was a bit more of an animal than it is now. Level 2 actually feels slightly stronger than before and Level 1 is a bit milder right now to try to make it a real economy tune. I am not seeing any improvements on mileage or only slight increases. I am going to go back to Level 2 for a while until I see some more improvements in mileage.
Coghlin,
Are you seeing lower EGT's on level 2 than the Beta level 1? I think I am. I will know thursday or friday on my return trip home. I was seeing continuous 700's @ 75 mph on I-40 across Arkansas yesterday. Today on a short stretch of I-40 on level 2 I was seeing low 600's @ 75 mph.
 

·
Registered
Joined
·
781 Posts
cowdoc;1621639; said:
Coghlin,
Are you seeing lower EGT's on level 2 than the Beta level 1? I think I am. I will know thursday or friday on my return trip home. I was seeing continuous 700's @ 75 mph on I-40 across Arkansas yesterday. Today on a short stretch of I-40 on level 2 I was seeing low 600's @ 75 mph.
I've been testing the bete 1 level and typically see mid to low 700's at about 70mph. Is this high?
I just set it for level 2 tonight, so I'll see what it reads on the way to work tomorrow.
 

·
Registered
Joined
·
1,257 Posts
Zick;1621715; said:
I've been testing the bete 1 level and typically see mid to low 700's at about 70mph. Is this high?
I just set it for level 2 tonight, so I'll see what it reads on the way to work tomorrow.
Seems high to me! Anyone else have an opinion?
 

·
Registered
Joined
·
781 Posts
FYI
Level 2 on the way to work @ 70 mph, EGT's were avg 720*. Not much different.
 

·
Premium Member
Joined
·
9,683 Posts
EGT varies so widely based on thermocouple used, depth of insertion, vehicle weight, elevation, fuel etc. I'd not be worried about 700°f at cruise.
 

·
Registered
Joined
·
781 Posts
Kennedy;1623086; said:
EGT varies so widely based on thermocouple used, depth of insertion, vehicle weight, elevation, fuel etc. I'd not be worried about 700°f at cruise.
That's kind of what I was thinking. Thanks. :)
 

·
Registered
Joined
·
380 Posts
I would think it varies quite a bit. The level 1 does seem quite hot. I am interested to see it hooked to the trailer. I have not tried. Trailer is buried in snow and I haven't needed it for a couple weeks. I don't get level 1 to break 1300 very easily but cruising it runs hot compared to level 2. WOT level 2 is hotter but cruising I think level 1 is hotter. Maybe I am losing it though. I am starting to get baffled by this evo. Level 2 is nice but Level 3 is definately not as hot anymore and Level 1 is not yielding any better mileage from what I am seeing. I think they improved it now but it is only better than their old tune which lost mileage. I am starting to get frustrated with the evo.
 

·
Banned
Joined
·
525 Posts
My EGT quit working today. Do not know what happened. Just quit. It sometimes pops up a temp but only for a second or two. Everyhting else works fine.

Any clues? I have had the EVO in my truck for a week.
 

·
Registered
Joined
·
76 Posts
eggsack;1628629; said:
My EGT quit working today. Do not know what happened. Just quit. It sometimes pops up a temp but only for a second or two. Everyhting else works fine.

Any clues? I have had the EVO in my truck for a week.
mine does this alot, just unplug probe connection at ob port then plug it back in and it should come back on
 

·
Registered
Joined
·
497 Posts
i doubt it

adgr71;1633809; said:
mine does this alot, just unplug probe connection at ob port then plug it back in and it should come back on
yea my egt's also quit after about a week they would go to 2000* to 900* at just idle then it stoped all together. called edge they said send'em back the thermocoupler and that wire that runs from it an they'll send me new one. ???:(
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top