Diesel Place banner

1 - 8 of 8 Posts

·
Registered
Joined
·
473 Posts
Discussion Starter #1
I finally tried to put the High Idle on my Duramax. Must of done something wrong. We followed the direction available on Kennedy's Website. For some reason it will not work. We have double checked, and just can't figure what we did wrong. Anyone have any suggestions? The instructions are straight forward and easy to understand.
 

·
Registered
Joined
·
812 Posts
Per the GM Upfitters article, it might take a few minutes the first time for the computer to recognize the new addition. Just a thought. Will be installing mine tonight. Another thought, do you have the cruise control turned on?
 

·
Registered
Joined
·
473 Posts
Discussion Starter #3
We tried to let it sit for over 30 minutes. Did see were it may take a few minutes the first time. We did make sure the Cruse Control was turned on. Tried pushing the set buttons a few times, anso the Resume. I can't see were we went wrong. I will be wating to see how yours goes tonight. Thanks For the Reply. Any suggesting will be helpful.
 

·
Registered
Joined
·
812 Posts
Couldn't log in last night to get back with you, but I did get it installed. Happy to report it worked on the first try. Even taught the wife how to work it. I ran the first wire from C-71 to the switch on the dash. The 2nd wire from the switch to a super bright LED and then to a swicthed fuse in the panel by the door. Turn switch on to complete the circuit, turn cruise on and hit SET. It went to 1250 rpm as advertised and RESUME went to 1750 rpm. Stepped on brake to confirm it all works. Now trying to explain to the boneheads at work why I did this is another story. Hope you get it work soon....
 

·
Registered
Joined
·
16,610 Posts
Make sure the pin is pushed through all the way. If you didn't remove the blue translucent cover, chances are you don't have it in all the way.
 

·
Registered
Joined
·
473 Posts
Discussion Starter #6
Max Power, We tried that the first thing this morning, well that was not the problem. I had read that on another forum. It has us scratching our heads. We tried to call dmaxalliTech this morning, he was busy and hasn't returned our call. We are going to contact GMUpfitters and see if they have any suggestions. It seems like everything I try Murphy's Law goes into effect. It takes 3 days to do a 45 min job!!!!!
 

·
Registered
Joined
·
473 Posts
Discussion Starter #7
Finally got my high idle working!!!! It is along story, don't have time to tell all the steps. We set the 2 settings one at 1250 rpm's and the other to 1650 rpm's. We felt like a couple of dummies. It sure is going to be nice to have high idle on a cold morning. Below is a picture of how I put my Switch.


 

·
Registered
Joined
·
29 Posts
After looking at some of the topics, I'm blown away! I'm a new Diesel owner and was looking in to the Htpertech Power Programmer III. Good or bad investment? Will I get much if I couple it with a new K/N intake?
 
1 - 8 of 8 Posts
Top