Diesel Place banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,259 Posts
Discussion Starter #1
Sorry CR, But I think I'm catching what you got.Yesterday I got an SES light and after pulling the codes it was a 35, I'm going to change the fuel filter and hope for the best, It runs fine, after searching old posts it could be air/fuel filter/PMD or IP, If I have any luck it will be a filter. The SES seemed to occur when I tried to engage cruise, which BTW quite working at the exact same time as the SES occured, today on the way to work the cruise works again and there was no SES lite. I lent out my scanner so until I get it back I can't check the Data Stream.I hope I got the truck away from CR before all the bad Karma was looking for a place to reside (LOL)As an update I've logged about 1000Kms on my new engine and the truck has recieved 3 oil changes and seems to be working well,(except for DTC35) I still need a set of injectors though.
 

·
Registered
Joined
·
590 Posts
Take a fuel sample ansd see if there is water in it. Mine did the same thing last year.
 

·
Registered
Joined
·
3,598 Posts
Better you than me... I've had enough already!
 

·
Registered
Joined
·
7,432 Posts
Notice your luck changed for worse when his changed for the better. Hmmmm. Looks bad, but somebody needed to take the "Rigger" bad luck.
 

·
Registered
Joined
·
1,259 Posts
Discussion Starter #6
I gotta take the "CanadianRigger.Com" sign off my back window, I think the Bad found it's way to my house!
I decided I don't want what you got rid of Russel.

Glad you got yours up and running again
Nick
 

·
Registered
Joined
·
3,598 Posts
I gotta take the "CanadianRigger.Com" sign off my back window, I think the Bad found it's way to my house!
I decided I don't want what you got rid of Russel.

Glad you got yours up and running again
Nick
Well, its running at least.

Scared the liven be-Jesus out of me on the way home tonight when a IC tube blew off the turbo!!! I damn near had a heart attack right there.

Ya know even a heavily modded 6.5 is pretty much worthless without a turbo!

Oh, and you can replace that sign off the back window with "Dieselfever.com" if you like instead!
 

·
Registered
Joined
·
8,014 Posts
Did the same thing with mine CR, but had about 15K of tractor and trailer when mine blew off, going uphill no less, things got ugly fast, quality T bolt clamps only way to keep it together.
 

·
Registered
Joined
·
3,598 Posts
About 1/2 of my clamps are the T clamps with springs, they stayed on. The one that blew off came right off the Holset, maybe its time to invest in some GM gooo...lol
 

·
Registered
Joined
·
8,014 Posts
Got a bead or crimp in the tube, shouldn't need the goop then, though red RTV does a good job
 

·
Registered
Joined
·
3,598 Posts
I'll post pics in a bit, i've been lazy and have to go fix it now... lol
 
1 - 11 of 11 Posts
Top