Diesel Place banner

1 - 4 of 4 Posts

·
Banned
Joined
·
2,530 Posts
Discussion Starter #1
Well, its finally here...winter! Normally this isn't too bad, but when I go for a ride in my 8 month old truck and the defrost doesn't work for crap, I'm not a happy camper. With the engine temp at 190, the defrost on 85 and the fan on high, it wouldn't even defog the windshield!!! The defrost in my 64 falcon works better than this. I guess I'll be cruising out to see Eric as soon as the weather is nice for a couple days. UUUHHHGGG!!!
 

·
Registered
Joined
·
16,610 Posts
Definately something wrong. I do think that the fan blew better on my 01 but it definately will clear the windshield and I bet its a lot colder here then there


Down to -15<SUP>o</SUP>F tonight. Brrrrr.Edited by: Max Power
 

·
Registered
Joined
·
7,187 Posts
BlueOx03 said:
Well, its finally here...winter! Normally this isn't too bad, but when I go for a ride in my 8 month old truck and the defrost doesn't work for crap, I'm not a happy camper. With the engine temp at 190, the defrost on 85 and the fan on high, it wouldn't even defog the windshield!!! The defrost in my 64 falcon works better than this. I guess I'll be cruising out to see Eric as soon as the weather is nice for a couple days. UUUHHHGGG!!!

Close the rear vents in the console.............


I had the same problem when i got my truck, learned real fast.





T
NY
 

·
Registered
Joined
·
112 Posts
I think the fans are too weak in these rigs. In my Tundra I was able to run on the split defrost/heat setting and still had plenty blow power to get the job done.


A mod possibility?
 
1 - 4 of 4 Posts
Top