Diesel Place banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,923 Posts
Discussion Starter #1
I have right around 18,000 mile on my 03 and I am getting increasingly anoyed at the cruise dropping 4 mph after getting in the throttle to pass someone. And everytime I set ti it takes off, increasing the speed by 2 mph and then backing off.... Is there a computer fix for this yet... And do the 01-02s do it?





It sucks bad....
 

·
Banned
Joined
·
6,539 Posts
My 01 started doing it after I got the reflash for shift business. Not too bad unless I run propane. It has trouble dealing with the boost/power surge. SOmetimes it's really noticable. On relatively flat highway it works fine, lp off. I believe they are allowing slightly more speed drop so it doesn't downshift as much. The problem is once it hits the bottom threshhold, it reapplies throttle to take it back up and the cycle continues. If you are using a performance enhancer... it seems to aggrivate it.Edited by: hoot
 

·
Registered
Joined
·
1,381 Posts
Mine does the same thing. Really annoying when towing in the Texas Hill Country. BTW, some of the hillS around here work me over worse than 6% grades in the Rockies. Kinda like towing on a roller coaster.
Edited by: cdhd2001
 

·
Registered
Joined
·
71 Posts
I know that this post was from a while back, but I just took delivery of my new '04 and it also does this. Does GM have a new software flash for this????





BTW, I am an engineer and have worked with control systems, someone please tell GM to turn down the gain and increase the integral just a little :) (if it is only a PI control) If it is a PID control, then turn up the D just a little too
Edited by: mnstr_fx
 

·
Registered
Joined
·
692 Posts
never hear of a reflach have had d/max owners state this i feel the cruse handle and button are kind of hokey. on some vechocles there are seperate buttons onthe steering wheel it seem to make it easier. also remember how senstitive all the sensors are. just because you have it set at 65 will not always prove to hit that mark it is all dependent on load, incline, decline, wind can all effect the cruse.
 

·
Registered
Joined
·
71 Posts
I realize that there are a lot of parameters which effect how well a cruise control works .... BUT!!! I have owned many GM vehicles over the past 15 years and all of them worked flawlessly. In fact, I even perferred them to other cruise controls since they were way too touchy and didn't maintain speed very well. My complaint occurs both unloaded / loaded, and was never a problem with any of the other GM trucks I have used. I just wish the EE who programmed these trucks would take a short test drive and do a little "tuning" of the cruise control system.


Anyone else think the cruise control on the D/A setup is just a little too touchy and does not hold speed very well???
 

·
Registered
Joined
·
78 Posts
I run the manual and have similar problems with my cruise. It seems like the cruise waits to drop to much speed before trying to pick up when on rolling hilly road. After it picks up, the turbo seems to be really spooling about the time it is going by the set speed so, it overshoots it. It is really annoying when I have the trailer behind it as it is worse then. Especially when I am pulling somewhere with a group of vehicles and my Dodge buddies just laugh at me on the radio as there cruise does not do that.
 

·
Registered
Joined
·
958 Posts
I've got the same issue as camp with my manny tranny, kinda annoying, especially when the hills are spaced just right so that it keeps doing it over and over again.. And if I help it with my foot at the base of the hill, when I try to "line it up" at the right speed once the ground levels off, it will drop a few mph then catch up again.
 

·
Registered
Joined
·
2,989 Posts
Our '04 hasn't done it..... at least not yet that I have noticed. Will keep an eye out for it though, maybe it has and went unnoticed.
 
1 - 11 of 11 Posts
Top