Diesel Place banner

1 - 20 of 75 Posts

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #1 (Edited)
So I finally swapped my T/S switch on the hope that the truck will now have cruise. After two hours of messing with it(BTW yes I did install the fuse for it also) no good. So I guess that's that. Time to look at whether it's a different ECM. Everything went together nice and wipres, T/S work fine. Just no criuse. What a dissapointment. I have a bad cold and possible a touch of flu but had planned this weekend for the swap and I wasn't giving in. Here's the pics . I wanted to do an extensive write up upon success of all the little things you run into that aren't in the book but why bother it won't work anyway.:damnit1::shootself:cussing::(
 

Attachments

·
Registered
Joined
·
1,182 Posts
LMAO, is that a "Mr T" air freshener in the first pic? I need one of those to hang off the mirror!

on edit: sorry it didn't work.
 

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #3
LMAO, is that a "Mr T" air freshener in the first pic? I need one of those to hang off the mirror!

on edit: sorry it didn't work.
Yes it is. And I'm proud of it !!!:D
Smells just like his armpits..:D
 

·
Registered
Joined
·
1,182 Posts

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #5
Hey I was thinking on this. My ECM was replaced by a local shop with a junkyard one. It said on it in yellow junkyard paint 96 3500 Diesel. When I went through this with Bill Heath he had me pull the ECM and give him the #s on the chip and also (painstakingly) get the Numbers off the IP. He said the chip I had belonged in a 1 ton ambulance and he was surprised the truck ran at all. So he set me up with a Maxi Torque( not the newest one mine is about 4-6 months old)said it would clear up my problems. He even offered to try and find me a stock one that belonged in the truck if I wanted to but I went with the Maxi. Truck runs great tranny feels great etc. My question is isn't a 96 OBD II and if I pulled the chip myself and replaced it with a Heath then my ECM can't be out of a 96 correct ? I'm wondering if this junkyard ECM somehow is not programmed for Criuse. Is that possible ?
 

·
Registered
Joined
·
905 Posts
the 96 3500 may not have had cruise control....if it came from a plane jane cab & chassie it might not have...was there any extra plugs or wires?....might be some pins missin' on that ecm
 

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #7 (Edited)
Thats what I'm trying to figure out but would a 96 3500 ECM be OBD1 because my Tahoe defintely is. My line of thinging here is around 96 when airbags became standard and so did OBD 2 that heavy duty vehichles such as 3500 series were still exempt. Like my 2000 has no airbag.
 

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #8
Now I'm getting nervous that may be my problem I may be calling Heath tommorow about this one. I hope the chip will work in a different ECM. That would suck. If it even is the problem.
 

·
Registered
Joined
·
905 Posts
i thought 96's where OBDII...just 94 & 95 where OBD1????....you have to send the ECM to him for OBDII....you just change the chip for OBD1...thats the way it says on his site..
 

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #10
You know Dammit when I posted about that Tahoe 2 door at the junkyard I remember looking at the ECM saying to myself I should buy that it probably is the right one for my truck. I'll bet it's gone now.
 

·
Registered
Joined
·
3,222 Posts
Hey, ask heath about the chip if the programming is on the chip or the ECM about the cruise... wondering if there is a problem in the system somewhere that is hindering it from working... like a code or something maybe?
 

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #12
no codes.
 

·
Super Moderator A Country Boy Can Survive...
Joined
·
14,351 Posts
hey aces. this is on your 95 tahoe correct? just for shits and giggles wheres your PMD? i know when those started to go bad you would lose cruise control. i see your 2000 has the heath kit though.
 

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #14 (Edited)
Still on the pump and factory no issues with it yet but I think my problem is the wrong ECM in the truck. Gonna call the junkyard tommorow that had that Tahoe. It was the twin to mine and had cruise. I just hope they still have the ECM. I have the relocate kit for my PMD but I was waiting till I had time to do everything in one shot.
New glows
new injectors
F intake swap
and finally PMD relocate.
If the ecm fixes it then I'll do an extensive writeup on the details of the swap.
 

·
Super Moderator A Country Boy Can Survive...
Joined
·
14,351 Posts
what relocate kit do you have? i'm guessing heath's? i'd say try the PMD kit first. maybe you'll get lucky. i believe that the cruise control fails before anything major like stalling, etc, etc happens. not sure on that one though. but maybe since you've got the kit you may not have to spend the money on that ECM. could save you a few bucks. worth a try. either way good luck figuring this out. i wanna know how it goes because i've got a busted hazard light switch so i'll be replaced the turn signal switch soon and want to get one with cruise if possible. thanks aces.

- Dave
 

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #16 (Edited)
I'll let you know. I still think it's the ECM because it was swapped on this truck and out of a 3500 with possibly no cruise.Like I said once I get it figured out I'll do an in detail write up. There are things I encountered that are not in the book.
 

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #17
got a bad cold. Been up all night just waiting for the junkyard to open. Wish I new for sure if the ecms could be different.
Anybody ?:banghead:
 

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #18
no codes.
I thought about that too. For the life of me I can't remember when i ordered the Maxi torque if Bill asked about cruise. That would suck if that was it.
 

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #19
Junkyard sold it. I'm screwed.:(
Is a 1994 ECM same as a 1995 ? Anybody use Walts remans ?
 

·
Forum Troll
Joined
·
5,969 Posts
Discussion Starter #20 (Edited)
:help:
OK guys in Electrical forum got me a print for my truck but I'm asking here too because this is where the pros on old trucks are.
All 3 wires from T/S switch for the cruise tested good at respective ends at the ECM so I gotta believe the truck is wired for cruise and that I just either have a problem or somehow missed something ?? Still no word from Heath if the maxitorque may lack programming for it or would even affect it.
Now I'm stuck.
If I can figure this out alot of people will want to do this but I'm behind the times with the new stuff. What should I do next ?
Also one thing I didn't mention before. The ABS module is bad in the truck and light is on. Any chance that would affect it ?
 
1 - 20 of 75 Posts
Top