Diesel Place banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi Folks,
Here is what has happend to me.. My 2001 started to lose coolant about 3 weeks ago .. I added about 1 1/2 to 2 quarts of anti freeze when the Low Collant Light Came On.. I was ok for about 3 days & the Light came back on again ... I started to wonder at that point if i had a problem .. I again added anti freeze to fill it up .. Again the Light came on..You could Smell the coolant .. so i called the dealer took it in .. there is a TSB on the truck with ( Loss of coolant no visible leaks ) .. The dealer also confirmed that the truck was losing anti freeze .. He did like the TSB said to do the pressure test Cold... the left the pressure test on for 3 days no loss in pressure plus he completed the rest of the steps the TSB called for. it was not good he could not find any leak.. he had to call GM Tech support .. got a ticket# for the truck .. GM tech support now wanted him to redo the TEST HOT... so then ran the truck for about 3 hrs.. still couln't find any leak.. but losing anit freeze.. he stated that they then put on another pressure test this time there was a loss in pressure.. but no visible leak .. so now where is the anit freeze going.. then they seen a Drip.. on the floor.. after looking they found the leak in the rear of the motor comming from the flywheel housing .. it was spraying out .. he didn't tell me or show me exactly where .. but he stated that there are 2 O Rings they believe are bad... hes stated that from the location of the leak that it was almost impossible to see it.. if they had not seen it at that point they were going to rip the motor down.. he also stated that with the location it's not going to be easy to replace this so they may have to pull the motor.. he's not sure.. Thank gawd it's still under warranty i'm enclosing a picture of where the O RINGS are located.. you will see , where the dealer scratched the locations of the O RINGS .. I hope this information may help others with similar problems.. also i would like to hear if this has happened to anyone else..? BTW the truck has been down now for 4 weeks trying to find this leak ... i hope the picture works.. :)
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter #2
Oppps... Sorry guys BTW i Have 50,000 miles on the truck.. didn't want to forget that... Sorry again..
 

·
Registered
Joined
·
1,069 Posts
oops
 

·
Registered
Joined
·
12,262 Posts
Never heard of that one. My weep hole weeps a tad of erl only.Think the rear main weeps a little never spots although.I would have guessed the Turbo coolant lines for the coolant leak.

Mine leaked dripped down in the same area you mention.
 
1 - 4 of 4 Posts
Top