Diesel Place banner
1 - 3 of 3 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
This morning I started my truck and it idled very rough and sounded as loud as a Powerstroke. The service engine light soon came on and I turned it off after running 2 or 3 minutes. I waited about 10 minutes then started it again to move it back into the garage as I was afraid it would damage the engine to drive it this way. It ran fine with the service engine light still on, so I drove it to town and warmed it up. (outside temp 35f). It ran fine and the check engine light went off. I tried to drain any water from the fuel filter and nothing, not even fuel came out. I changed the filter about 10k ago. Edited by: Walter
 

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
What do you mean, "crack the bleeder"? I opened the bleeder until it felt like it would fall out and got nothing from the filter. My dealer says 1 to 2 hours to pull the code. this seems ridiculous. I do plan to change the filter tomorrow. The last time I changed it, it took about 1 hr. and some skinned knuckels. Wish Chevy would have put it in an easier spot to get to. I really apprecitate the help. Thanks
 

· Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Thanks a lot Eric, I think this will help a lot and I think this is the greatest website, I have ever seen. I am very new to this site and must read some of the other info and get familiar with it. I purchased a NAPA filter and hope it is good quality.


Thanks again,


Walt
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top