Diesel Place banner

1 - 6 of 6 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
I'm new to this forum, but I've found it very helpful. With hours of searching archives, I was coming up empty with this weird "clunking" noise in my truck. I've made a few posts in some of the other topics regarding this issue.
The symptoms were as follows: clunking noise was intermittent, whether the engine/transmission temps were cold or at operating temps, whether in Park or Drive, and only noticed when idling or on decel/coasting. the noise seems to be felt more in the passenger floorboard. It has been going on for 6-8 weeks, and seems worse on warmer days.
Well, I found the cause today, and it's going to the dealer in the morning. I was really pulling my hair out trying to figure this one out. So I turned the A/C switch off, and the noise stopped! I hit the switch again...and "CLUNK"! It was consistent. Definitely coincided with the compressor turning on.
So I guess the clunking I'm experiencing is an issue with the compressor. Anyone else heard anything like this wrong with their trucks?

Thanks for hearing me out. I hope this helps others if they are experiencing the same thing.

See ya,
 

·
Registered
Joined
·
5,108 Posts
dang A/C.. you don't need it, rip it out!! ;-)
 

·
Banned
Joined
·
1,214 Posts
mine kinda clunks too when the clutch comes on, but it still works, so i don't care
 

·
Registered
Joined
·
1,286 Posts
I notice mine doing it also... Mostly when sitting at red lights.... Please let me know what the dealer does for you...
 

·
Registered
Joined
·
167 Posts
Mine does it too. Let us know if they replace anything or just tell you "working as intended".
 

·
Registered
Joined
·
53 Posts
Discussion Starter #6
Well, back from the dealership. They reflashed the PCM to take care of the Turbo Bark. The a/c compressor wasn't making near as much noise by the time I got there...keep in mind a 40 mile drive in 55 degree weather. You guessed it "working as intended". I'm not worried now, as I know there isn't a drivability issue, and hey, it's under warranty. There are no TSB's on the a/c compressors or associated clutch. I had them change the oil and filter, as well as the transmission filter. I'll do a power flush on the tranny, change the oil in the differentials, and probably have the radiator power flushed at 30k miles.
I plan on keeping this baby for awhile.
Oh, by the way, I didn't even bother to take my Edge controller off (Juice w/ Attitude). They worked around it and said no problem. They didn't even disconnect it to do the reflash, and everything seems fine. They said they'd rather have it on than to risk bunging up the harnesses by repeatedly connecting/disconnecting it. They also mentioned there are no replacement parts for it, so basically they believed if you messed up the harness, you were looking at rewiring the entire engine!
Cool dealership!
 
1 - 6 of 6 Posts
Top