Diesel Place banner

1 - 3 of 3 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Hey y'all!

So I've been getting some progress over the last few days, and I'm hoping to finish this up before the winter arrives.

I've located 2 leaks - one is from the transfer case leaking ATF, the other one is from the rubber fuel hoses connecting to the FFM.

The rubber hoses connected to the FFM is completely rotten, I tried replacing the clamps on the hoses to no avail. I'm considering pulling the FFM out and reinstalling it with some clear plastic "marine" hoses - any thoughts on this?

I've also got this weird "clicking" noise as coming on when I turn the key to the "ON" position, as the lift pump is working. I've put a video of it below. I was hoping on some insight on this clicking sound, and I'm hoping it will disappear when I install those new hoses. I've been thinking that it could be from the FFM not getting enough fuel delivered?

Anyway here is the video - I hope some of y'all knowledgeables could take a look and maybe some 2 cents!

 

·
Registered
Joined
·
4,233 Posts
That is the glow plug relay, the wait to start light will glow on and off in unison with the clicks.
 
  • Like
Reactions: OkDually

·
Administrator
Joined
·
18,470 Posts
Hey y'all!

So I've been getting some progress over the last few days, and I'm hoping to finish this up before the winter arrives.

I've located 2 leaks - one is from the transfer case leaking ATF, the other one is from the rubber fuel hoses connecting to the FFM.

The rubber hoses connected to the FFM is completely rotten, I tried replacing the clamps on the hoses to no avail. I'm considering pulling the FFM out and reinstalling it with some clear plastic "marine" hoses - any thoughts on this?

I've also got this weird "clicking" noise as coming on when I turn the key to the "ON" position, as the lift pump is working. I've put a video of it below. I was hoping on some insight on this clicking sound, and I'm hoping it will disappear when I install those new hoses. I've been thinking that it could be from the FFM not getting enough fuel delivered?

Anyway here is the video - I hope some of y'all knowledgeables could take a look and maybe some 2 cents!

I would just replace all 3 hoses to/from the FFM with rubber hose.
 
1 - 3 of 3 Posts
Top