Diesel Place banner
61 - 80 of 419 Posts

·
Registered
Joined
·
208 Posts
My dealer was in contact with GM engineering today. They see there is a problem on some trucks but have no idea what to do. Some trucks seem to respond to a different brand of Def but some do not. Changing Nox sensors seem to help some trucks for awhile. The air cooler pipe in a few were found at fault. This is sad for such an otherwise great truck. I'm hoping something develops soon. Truck has been in shop more than two weeks.
 

·
Registered
Joined
·
208 Posts
The code P20EE has been off and on at least a dozen or more times. Truck has been to three dealers in two states. This dealer seems to want to resolve this issue. However, at this point no one knows what to do. Yes very frustrating on a new truck.
 

·
Registered
Joined
·
208 Posts
Not sure what you are asking but No, everyone's truck is not running right.
This problem with CEL is not wide spread but there are a few cases here.
 

·
Premium Member
Joined
·
139 Posts
On our way to dinner in my brand spanking new 2018 LTZ with the new and greatest L5P Duramax ever. 262 miles and still learning what all that information on the dash is telling me, and there it is, the CEL. I could have puked, actually hours later, I still can if I let myself. Bought it a a "friends" dealership about 185 miles away. That actually turned out be of no value. The local dealership is small and I have no trust in what so ever. Words can not express..
 

·
Registered
Joined
·
37 Posts
Dang, you have a 2018 already?

You're not alone, although yours hit sooner than mine did at 485 miles. Give a dealer a shot to fix it for you. I had one NOx sensor replaced and fresh DEF put in. Last CEL was before 6K. I'm about to hit 15K miles on my '17 and have not had it come back since. Yes it's a crappy feeling and I was pissed. But hopefully you can get yours resolved. Please keep us posted.
 

·
Registered
Joined
·
208 Posts
I feel your pain..... My cel P20ee first came on at 275 miles. And more than a dozen times since. They will tell you it is the def. BS on that. There seems to be no fix at this time per dealer and GM customer service. I believe they will find the answer, eventually. In the mean time we need to keep the pressure on.
 

·
Premium Member
Joined
·
139 Posts
This is the BS I went thru with the '11. Temporary fixes for 4 years till off warranty then had it deleted. I feared this. And so it all begins again.
 

·
Premium Member
Joined
·
139 Posts
I spoke with On Star just now. Codes P0422 and P2480. She read the first excuse to me. Emissions malfunctioning to put it short and to have it serviced within 7 days. She then said the second code was the same but to have it serviced at my convenience. I have an appointment Monday 8AM with a dealer I've never liked, but closest.
 

·
Registered
Joined
·
39 Posts
I spoke with On Star just now. Codes P0422 and P2480. She read the first excuse to me. Emissions malfunctioning to put it short and to have it serviced within 7 days. She then said the second code was the same but to have it serviced at my convenience. I have an appointment Monday 8AM with a dealer I've never liked, but closest.


They changed both nox sensors on the exhaust. Seems to fix the problem?
 

·
Registered
Joined
·
19 Posts
I'm still waiting to hear back from dealer told keep driving it. Since they have no clue and they've throw all kinds of "maybe this maybe that" but never sure. I cleared the code 200miles ago and waiting for it to come back on. There waiting on GM to give them more info but for now it's like a game of when it's going to come back on. Three times now. Ugh someone make a freaking delete already.
 

·
Premium Member
Joined
·
139 Posts
Delete, ah. I have a perfectly sweet 2011 across the street for sale. An 2018 in driveway with a CEL. Who says lightning doesn't strike in the same spot twice. '18 deleted, very sweet.
 

·
Registered
Joined
·
373 Posts
Delete, ah. I have a perfectly sweet 2011 across the street for sale. An 2018 in driveway with a CEL. Who says lightning doesn't strike in the same spot twice. '18 deleted, very sweet.
Man, sorry to hear about the CEL, especially when you had reservations about buying one. Hopefully this is a software related issue that's addressed soon.
 

·
Registered
Joined
·
208 Posts
I kind of believe it is a software issue. My truck has had the Nox senser, Def injector and the Def replaced twice. Also the tank was dropped to check the pump. The turbo cooler pipe checked for proper alignment. The Cel has come back on after every "fix".
It was in the shop for three weeks last time alone. This needs to get resolved !!
 

·
Registered
Joined
·
19 Posts
Yes I had a 2012 deleted from new after first oil change never had one problem with it 100k when I sold her for this L5P ? Delete for this one would be heaven ?
 

·
Registered
Joined
·
3,081 Posts
:banghead:

:confuzeld

:shake:
 
61 - 80 of 419 Posts
Top