Diesel Place banner

1 - 4 of 4 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
I installed the edge juice three days ago. I have a new unifilter I was going to install once I put my 4" exhaust on. I decided to put it in. I drove it all day approx 100 mi. I didn't notice any difference so I decided to put my stock air filter back in until I install my exhaust. I then drove approx 2 mi to car wash and my check engine light came on.
Can anyone help? I realize it could be the MAF but what should I do first? The truck runs great I love the power!
Edited by: 2thdr
 

·
Registered
Joined
·
12,262 Posts
What you need to do is get a hold of as code reader and find out what is setting the MIL .. Try a local AutoZone or a friend or member with a Pred or Quad box...





Could be as simple as a dirty Mass air sensor to perhaps a bad connection at the bale conector .. But you need the DTC to diagnose ...





Mac
 

·
Registered
Joined
·
83 Posts
Discussion Starter #3
Thanks for the reply. How do I clean the MAF? Is there a way to reset the check engine light? So many ?'s. I'm sorry but I am in a slight panic. The last thing I need is for my wife to see the light. Then I'll have to hear "I told you that was going to mess up your truck!"
 

·
Registered
Joined
·
12,262 Posts
Like I haven't heard that a couple times .....


The light will reset after a certain number of ignition cycles ..... Clean the Mass Air with an alcohol base product other then Scotch or Vodka .....


A good quality electrical cleaner ..... Or sha'wish around in rubbing alcohol and allow to completely dry .... Do not touch or wipe wire, very fragile ...

Don't panic tell her it's the low fuel lamp ....

Mac
 
1 - 4 of 4 Posts
Top