Diesel Place banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
First Post but have got some great info from everyone here - thanks. I was headed to Denver yesterday and while heading up through Vail pass began to lose power. At that time the Check Engine Light came on. I had just filled up 30 - 40 miles earlier. I noticed that I was kicking out some good black smoke in what seemed like "puffs". I stopped, shut the engine down and started it back up and it seemed to run better. The light finally went off when I got to Denver but then on the way home the same thing happened. It was like it was on cruise control at a low speed and won't take any more throttle - gas mileage was good as well going up the hill which I felt was weird. Fuel Filter?
A lot of info here, sorry. Oh and I lost my speedometer as well. Thanks
 

·
Registered
Joined
·
2,194 Posts
Stumpgrinder;1594110; said:
First Post but have got some great info from everyone here - thanks. I was headed to Denver yesterday and while heading up through Vail pass began to lose power. At that time the Check Engine Light came on. I had just filled up 30 - 40 miles earlier. I noticed that I was kicking out some good black smoke in what seemed like "puffs". I stopped, shut the engine down and started it back up and it seemed to run better. The light finally went off when I got to Denver but then on the way home the same thing happened. It was like it was on cruise control at a low speed and won't take any more throttle - gas mileage was good as well going up the hill which I felt was weird. Fuel Filter?
A lot of info here, sorry. Oh and I lost my speedometer as well. Thanks
hard to tell, what is happing w/motor/tranny??? get some codes read,But the speedo,is a gm flaw.
 

·
Registered
Joined
·
4,140 Posts
Get the codes and post them.
Check the fuel filter, air filter and the fuel.
Might want to check the oil and make sure there's no fuel in it also.

For the speedo. Odds are, your out of warranty. So you have a couple of options. Buy a new one from the dealer (expensive), Have yours repaired (much cheaper). Fix it your self (a fraction of the cost of the other options) A search for "speedo repair" or "cluster repair" should get you a ton of info. Here's a link to the cluster repair thread.

And...Welcome to the forum
 

·
Registered
Joined
·
1,653 Posts
My guess is that it was cold up across the pass and your fuel was either gelling up or water was freezing. Lot's of gel issues this year.

jb
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
I added more fuel and drove for another 30 miles or so, the 'cel' has gone out so I'm thinking I just had some bad fuel - I've got to drive to Denver again this sunday so we'll see if it happens again - thanks for the responses.
 

·
Registered
Joined
·
13 Posts
My 2001 DMax did the same thing and a couple of codes came up to do with the transmission solenoid, if the codes come up again,, find out what the are.
 
1 - 6 of 6 Posts
Top