Diesel Place banner
1 - 14 of 14 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Have change ny fuel presure regulator on fuel pump and now the engine wont start
eny one have a god idea
LB7 engine

thanks in advance
Jorn Hansen
 

·
Administrator
Joined
·
21,844 Posts
Pump up the primer button on the fuel filter head till hard and try it
 

·
Administrator
Joined
·
21,844 Posts
have trayed servel times no result thanks
When you pump up the primer does it get hard/ stay hard?
If not you need to rebuild replace that filter head.
Any codes popped up?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #5 ·
When you pump up the primer does it get hard/ stay hard?
If not you need to rebuild replace that filter head.
Any codes popped up?
when pump it get hard as sun i turn the engine igan pump op again no code poppet up
i change only the FPR becorse when travel ny caravan i some times get the code P0093
alvays start perfect so i nead help to solve this problem.
regards
 

·
Administrator
Joined
·
21,844 Posts
when pump it get hard as sun i turn the engine igan pump op again no code poppet up
i change only the FPR becorse when travel ny caravan i some times get the code P0093
alvays start perfect so i nead help to solve this problem.
regards
Did you install an OEM FPR? Aftermarket brands have been known to cause an issue.
I would also pressurize the fuel system and look for any possible leaks.
Double-check all fuses
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #7 ·
OK have checked the fuse will du it again have checked the fuell system for leaks no leaks
how abaut the ficm ??
coming back after check
regards
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #8 ·
OK have checked the fuse will du it again have checked the fuell system for leaks no leaks
how abaut the ficm ??
coming back after check
regards
Now i have checket the votage to injectors on the orange/back or the orange/white vier is only 2volt with ignition on ????
so ppls. advice
 

·
Administrator
Joined
·
21,844 Posts
Now i have checket the votage to injectors on the orange/back or the orange/white vier is only 2volt with ignition on ????
so ppls. advice
Check the FICM harness for any rub through wire insulation, corrosion, loose connection, etc. especially around the FICM support bracket
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #10 ·
Check the FICM harness for any rub through wire insulation, corrosion, loose connection, etc. especially around the FICM support bracket
Have testet all wier from pluck on FICM to all injector nothing wrong ??
 

·
Administrator
Joined
·
21,844 Posts
Have testet all wier from pluck on FICM to all injector nothing wrong ??
Get a fresh can of diesel fuel . Run a line from the can to the Filter head and try to start and run the truck from the fresh fuel.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #12 ·
Get a fresh can of diesel fuel . Run a line from the can to the Filter head and try to start and run the truck from the fresh fuel.
as far i can se no voltage to my injector
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #14 ·
Install a jumper wire from the case of the ficm to a good ground on the frame. To test grounding of ficm.
have a good ground to the frame.

til no voltage to the orande/black and orange/white wier to injector
suprse to be 24volt with key on ?????
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top