Diesel Place banner

1 - 6 of 6 Posts

·
Registered
Joined
·
431 Posts
Discussion Starter #1
Ok long short of it truck died, replaced fuel filter, threw p0087 code pretty sure its frozen in the line between tank and filter, I was able to fill the filter and suck fuel out of the filter but nothing else any way after taking the filter off for the forth time in the single digit temps in the dark I accidently ripped off the wires on the (water in filter sensor?) Will it run once thawed without these attached? Old fiter deffinatly had something frozen in it could feel it. TIA
 

·
Registered
Joined
·
1,351 Posts
Yes it should. I had my 06 at the dealership not too long ago for some warranty and when I got home, I popped the hood to double check everything (I don't trust them). And I found that my water sensor was not plugged in at all. I had driven it that day after the dealer approximately 40 miles and the CEL never came on, and the truck ran just fine with no problems.
 

·
Registered
Joined
·
540 Posts
Is it up and running with the new filter? A friend just called and said his just died (-3*F). I'm wondering what might be the "BEST" way to deal with it if the truck can't be thawed.
 

·
Registered
Joined
·
9,606 Posts
Some Power Service 911 in the tank and in a new filter with a little diesel. Give it 20-30 mins see if it will start if it does let it idle for 15 mins then you should be good to go. If it won't start get some propane heaters and warn up the fuel line and filter just don't start the truck on fire or you can have it towed to a heated garage.
 

·
Registered
Joined
·
431 Posts
Discussion Starter #6
I was on the side of the road when it died, skipped the first part sort of tried another filter and some 1000W work lamps, went indirectly to heated garage after some heat and a 3rd fuel filter I am up and running again.........
 
1 - 6 of 6 Posts
Top