Diesel Place banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2,097 Posts
Discussion Starter #1
Anybody got any Ideas? I went into limp in Barstow , Changed my fuel filter , disconnected the Batts and the check engine lite went out and it ran fine to Baker then the check engine lite came on again and back to limp , if I shut it off it restarts runs fine goes 2blocks and back to limp , When it limps ot sounds like a Dodge but no smoke , this is Exactly what it did when the Injector harness went bad except it corrects limp mode evertime I shut it off and restart then right back to limp. trying to get it home to the dealer in Henderson NV and they want to tow to Barstow , am pulling my 48 ft trailer too!
 

·
Registered
Joined
·
179 Posts
so it's the engine limp, not a tranny limp?

no ideas but to help speed things up, any mods or bone stock?

hope you get it home with ease.:)
 

·
Registered
Joined
·
2,097 Posts
Discussion Starter #3
Engine limp . Pulled the edge first thing , has no engine mods except a Banks intercooler and exhaust , the intercooler was just installed by the dealer.
 

·
Registered
Joined
·
412 Posts
Do a detailed signature and you will get a lot more good info.....Hmmmm......Baker, CA, at least you can get a great burger at Bun-Boy and visit the worlds largest thermometer!
 

·
Registered
Joined
·
493 Posts
Seems like Vegas is just as far as Barstow. About an hour either way isn't it?
 

·
Registered
Joined
·
2,097 Posts
Discussion Starter #6
Anybody near Baker CA with a Code reader? There not even a parts store or real Garage here . 702-361-1928 Help!
 

·
Registered
Joined
·
4,755 Posts
Take a look at the pins in the 2 connectors where the edge was plugged in. Sometimes they get pushed into the housing and when you plug them back in they do not make a good connection. Use a small pair of needle nose plier to gently pull out the terminals. If some pull out with light pressure you may have found your problem. Make sure to disconnect the batteries before doing this.
 

·
Registered
Joined
·
62 Posts
****, Next week I would be there with a code reader, sorry can;t get there this week. Man, that place is like being on the moon. You might ask at the 76 station if there are any mechs in town. Just don't go to that rip off shell station at the east end of town. Hope you get it going again.
 

·
Registered
Joined
·
954 Posts
sounds like one connector and maybe not the whole harness
 

·
Registered
Joined
·
161 Posts
You may have a broken injector connector but if they already replaced them who knows. I have seen fuel leaking into your fuel injector control on the right side of the engine and causing the same problem if this is the case you may be able to clean the fuel out of the connector and get you home.
good luck
 

·
Registered
Joined
·
2,097 Posts
Discussion Starter #12
Rick , I got it home and then to the dealer , Another bad injector harness , this time the dealer said they have a new harness made different to sit on the engine better and have less likleyhood of failure , left the trailer in Baker and got it home with no problem after messing with all the plugs and connectors , probably would have got the trailer home but Oh well! ,I guess I have to go back for the trailer. Good news on the LBZ front .
 
1 - 12 of 12 Posts
Top