Diesel Place banner

1 - 7 of 7 Posts

·
Banned
Joined
·
38 Posts
Discussion Starter #1
20,835 Miles. Driving on freeway at 70 and lost all power, CEL light on. Under mild accel edge on 3, first thought was limp but buy was I pissed liming in 3. Pulled over and pulled codes:

P0090
P0193
P0207
P2146
U0105

Was right in front of the dealership (on the way there actually to pick up unrelated parts). Pulled into a parking lot, busted out the tools and pulled the edge. Codes look like Injector 7, cylinder issues, fuel pressure, etc. Sounds like a damn rod is broken in half with how much noise its making. Service guy said depending how bad it is Ill be getting a new engine. Anyone ever had anything like this?

At first though the diesel tech said it sounded almost like gasoline in the fuel? I have 1/2 tank and havent filled up in a week and am 100% sure it was diesel... any other thoughts?
 

·
Registered
Joined
·
12,036 Posts
Edge isn't wild enough to do serious damage.

Good luck.
 

·
Registered
Joined
·
2,386 Posts

·
Banned
Joined
·
38 Posts
Discussion Starter #5
Too late for the kitty. Im not worried about it too much. I just did some searching and figured ou there is a TSB.... talks about too much strain on the injector harness and it ends up breaking for #2 and 7. I guess there is a new 90º harness that needs to be installed to fix the problem. Glad its nothing major and just a harness.
 

·
Banned
Joined
·
38 Posts
Discussion Starter #6
Thanks Max I just found that... Im gonna print that out and take it in in the morning. Knowing some of the stealership nitwits it will take 3 days to diagnose :(
 

·
Registered
Joined
·
272 Posts
i know a guy in Idaho that was an idiot and put 35 gallons of gas in a 135 gallon fuel tank (logging truck) and by the time he got to the landing site to load people said that flames were shooting out the stacks and the stacks were RED HOT. locked up the motor right there at the landing. So I don't think it had any gas in the diesel.
 
1 - 7 of 7 Posts
Top