Diesel Place banner

1 - 15 of 15 Posts

·
Registered
Joined
·
4,627 Posts
Discussion Starter #1
My truck started squeaking bad this weekend. Only occurs at cold idle, maybe even in mid range temps. Is there a TSB out on this? Need a new belt or what?
 

·
Registered
Joined
·
565 Posts
Mine does this sometimes too. It seems to me that the more moisture in the air (humidity) the more it squeaks. Its been dry lately and I havent heard it much. My old '03 LB7 did it all the time and my LBZ only does it once in a while. I had several belts replaced on my old truck, GM has a 12/12 warranty on belts so once every year I would get a new one covered under warranty.
 

·
Commissioner Gordon
Joined
·
5,139 Posts
Boss's new LBZ did it right off the lot, they put a new belt on @400miles, no more noise.
 

·
Registered
Joined
·
50 Posts
I had the same problem with my 04 they had to adjust pulleys. will my new 06 started doing the same thing Hum. Took back to the dealer they fixed it buy adjusting pulleys took all day. no sqeak so far.
 

·
Commissioner Gordon
Joined
·
5,139 Posts
um, there are no adjustments to pullys. The belt tensioner is suppose to hold the correct tension on the belt. They probably just hosed something down with lube. If it works it works.
 

·
Registered
Joined
·
346 Posts
They said that a couple of the ridges were too tight on my belt. Replaced the belt no problem.
 

·
Registered
Joined
·
139 Posts
I'm getting a new belt due to the squeek. All of 350 miles on it. They must have gotten a bad batch from the supplier.
 

·
Registered
Joined
·
405 Posts
My '06 LLY did the same thing at cold start up. Sometimes it would come back when the engine was warm but the majority of the noise was when the engine was cold. It sounded like a pulley but dealer said it's only the belt, they replaced it and it's been quiet ever since.
 

·
Registered
Joined
·
74 Posts
My truck started squeaking bad this weekend. Only occurs at cold idle, maybe even in mid range temps. Is there a TSB out on this? Need a new belt or what?
Dealer just replaced mine last week for the same thing. However, the idler pulley also has a slight "wobble" while running. I think that made mine squeal.. They told me that was not the problem. The belt was glazed. Still under warranty for 34k more miles
 

·
Registered
Joined
·
118 Posts
after the whole debacle i went though, mine still squeaks just a bit in start up, thats after 2 belts and a new tensioner (well thats waht the deler said they did). im pretty pissed. i think i might take it to my home town dealer in san antonio where i got it from (i got to college in college station) and if they can get it done. i just dont understand what it could be if they really chagned the belt 2 times along with the tensioner. sounds fishy to me.
 

·
Registered
Joined
·
139 Posts
I'm going in tomorrow for the belt squeaking again. They replaced the belt last time (which they had to special order). Hopefully belt number three will be the magic number..... yeah right.
 

·
Registered
Joined
·
139 Posts
Turns out this was the idler pulley bearing squeaking. Squeak gone for now.
 

·
Registered
Joined
·
2,530 Posts
Rttoys, the power steering pump pulley can be moved in or out on the shaft. Was a bulletin on some gas engines where pulleys were too far inward, saw one D-max like that.
 

·
Registered
Joined
·
139 Posts
Squeak back again.... Argh.... Truck is going in to the service dept on Tues, and they are going to keep it until they figure out the problem. I hate this sort of crap, it's just damn annoying, and I'll end up having to drive around in a Malibu for a week, gag.
 
1 - 15 of 15 Posts
Top