Diesel Place banner

21 - 23 of 23 Posts

·
Registered
Joined
·
1,021 Posts
They put some gooey red stuff on at the battery warehouse I go to - never had any problems with corrosion.
 

·
Registered
Joined
·
1,341 Posts
Mismatched battery update....

Okay, old thread, but I had to update....

Not about a 6.5, but a 7.3L Power Stroke diesel....

The one in my signature, a 1999, bought it in 2008. Date code on battery under hood was 2004. This year, 2017, I changed it due to a COLD winter and it having issues starting when COLD, COLD (ie below 20F to -1F) with out getting plugged in.

Any how, I went with a local Les Shwab brand. Their best....

What surprised me, is the two batteries (one under hood, one on frame rail) WERE NOT MATCHED! The under hood was a Motorcraft, the best one they had 100 month warranty. The frame rail one was an EXCIDE! Date codes were both from 2004! They were a few months apart in date code.... both the same BCI group (for the Ford). I'm "assuming" the CCA rating was the same, but I couldn't read the Excide. I have NO idea why they did that.... maybe the city shop or dealer didn't have two batteries of the same manufacture...

This van was a former city van and those two batteries were in there when I purchased it in 2008 with batteries coded 2004. And it is 2017 now.

13 years old! And they were mismatched.

I don't drive the van much, which may or may not be a good thing. I have had a slow drain and have to charge the batteries few times over the years....

Granted, MOST mismatched that people are talking about, are running a NEW battery with an old battery. Putting two NEW mismatched might be a whole different issue.... (there was one year of Ford van with the 7.3L IDI, the FACTORY used two batteries, but they were TWO different CCA ratings AND two different BCI groups..... go figure).

I just had to share...
 

·
Registered
1995 GMC Suburban
Joined
·
17,865 Posts
Okay, old thread, but I had to update....

Not about a 6.5, but a 7.3L Power Stroke diesel....

The one in my signature, a 1999, bought it in 2008. Date code on battery under hood was 2004. This year, 2017, I changed it due to a COLD winter and it having issues starting when COLD, COLD (ie below 20F to -1F) with out getting plugged in.

Any how, I went with a local Les Shwab brand. Their best....

What surprised me, is the two batteries (one under hood, one on frame rail) WERE NOT MATCHED! The under hood was a Motorcraft, the best one they had 100 month warranty. The frame rail one was an EXCIDE! Date codes were both from 2004! They were a few months apart in date code.... both the same BCI group (for the Ford). I'm "assuming" the CCA rating was the same, but I couldn't read the Excide. I have NO idea why they did that.... maybe the city shop or dealer didn't have two batteries of the same manufacture...

This van was a former city van and those two batteries were in there when I purchased it in 2008 with batteries coded 2004. And it is 2017 now.

13 years old! And they were mismatched.

I don't drive the van much, which may or may not be a good thing. I have had a slow drain and have to charge the batteries few times over the years....

Granted, MOST mismatched that people are talking about, are running a NEW battery with an old battery. Putting two NEW mismatched might be a whole different issue.... (there was one year of Ford van with the 7.3L IDI, the FACTORY used two batteries, but they were TWO different CCA ratings AND two different BCI groups..... go figure).

I just had to share...
Highlighted is the key, both the same type with presumably the same size.

It is easier if you go to a store to buy the same ones, though.

Mismatch that we are talking about in this forum are mostly buying 1 NEW battery and keeping 1 OLD battery.
 
  • Like
Reactions: VanBoy
21 - 23 of 23 Posts
Top