Diesel Place banner

1 - 20 of 36 Posts

·
Registered
Joined
·
369 Posts
Discussion Starter #1
@^$#&*($())%@[email protected]#%... friggen attitude i got does not work @#$%^)_)()*(*@@@@..... I got a 4.73 box and the attitude in the mail today, all happy to hook them up after rushing home from work and waiting a month for it to show up and see what it does, i plug in the juice, mount it on the fuse cover, run the wire for the attitude through the door, turn on truck attitude display lights up !!!!!!! HEY it WORKS
, so i think..... go to change the display so it will show 4 screens, (boost/throttle/egt/temp) and i can scroll down the menu but not select the 4 screen option, go up to the 3 screen option still cannot select it, go to the 2 screen option and it registers, try to access the menu buton again to go to 4 screen and nothing happens, hit enter nothing, hit up, hit down, hit menu, nothing happens
... it locked up like a crappy computer without a reset button
!!!!! I unplug it, unplug the juice truck starts up rund fine. Plug juice back in, truck starts up, i program the juice the old way with gear selector and gas pedal and it grunts for setting two that i programmed, at least something works. I program the T/H for setting three and it grunts three times. i shut it off, plug attitude back in fire truck, no buttons on attiutde work. It says power level 0, i do the PRNRP routine to verify power levels and sure enough the truck grunts the power levels i programmed even though the attitude says ZERO power level on the display....... I yanked the attitude from the truck and tested it the juice alone, itworks great, to bad the monitor isn't worth a chit...........
.








Anyone have any insight as to why this thing does not work??? i will have to call edge and see whats up on monday i suppose, what a bummer.......





second complaint is the pyro probe having EDGE products stamped on it, I'm sure the dealer will love to see that if the truck has to go in for service, guess i will have to add some heat shield to the length of the probe to cover that!!!!!!
 

·
Registered
Joined
·
11,646 Posts
Easy fella, you say you cant change power levels?? but all else works? Mine did the exact same thing, A quick call to Kennedy and we determined the truck must be warm some what..at least in my case, let it run for 10 minutes, went back to it and everything worked good...Not sure if is the same for you, but maybe....


Eric
 

·
Registered
Joined
·
267 Posts
gsxr,


Welcome to the club. I got my (replacement for the nonworking 4.71) 4.73 this morning, plugged it in only to find that the Attitude still had an attitude. I called Edge, they think it's the Attitude itself. This was the "first they'd heard of" - time will tell. Mine has EXACTLY the same symptoms you described. Not like it's really possible to screw it up - there's only one plug to plug in. I get no readings (RPM, etc) on the Attitude, even though the display lights up, etc...



BTW, Con has been EXCELLENT in support (and a GREAT price!!!), and is overnighting a new Attitude with Saturday delivery - after he'd overnighted the 4.73 replacement Edge for me today. Not like it's his fault or anything, but he has really gone out of his way. Hopefully I'll be in business with the second Attitude I get. If not, I'm going to deal straight through Edge and make them VERY aware of their product issues. Good luck...Edited by: Joe E
 

·
Registered
Joined
·
611 Posts
Oh so I'm not alone.


Got mine today pluged everthing truck starts fine, but there is nothing on the screen
. I can change power levels with the attitude, but I can't see anything on the screen. The only way I can confirm the levels is with "PRNP"
. I'm getting also a replacement tomorrow, just have to wait and see I guess.
 

·
Registered
Joined
·
611 Posts
I wonder, the only wires I didn't connect are the yellow & red wires that connect to the EGT cable.
 

·
Registered
Joined
·
267 Posts
Edge says the pyro should have nothing to do with it - I specifically indicated I had not hooked up the pyro yet. My display doesn't read RPM, anything...
 

·
Registered
Joined
·
611 Posts
Thanks Joe,


Mine has the same problem as yours, the display lights up but there is no data on it.
Edited by: DIESEL 5
 

·
Registered
Joined
·
369 Posts
Discussion Starter #8
My pyro is not hooked either, my display lights up but the values stay at 58 deg EGT and zero boost and zero power level and none of the buttons work at all... I suppose i coul just hook up the pyro without installing it, supposedeldly it makes no difference, but hey you never know.....





Joe E let me know if your new attitude works today, if it does i will tell my guy to send me a new one, wish i had gone with con's instead, he seems a lot more helpful than the guy i'm dealing with.... I got a good price and all, but the service and attitude needs some help......
 

·
Registered
Joined
·
267 Posts
I got my new Attitude this morning, ran out and plugged it and ALL IS WELL!!! WOOHOO!!! All functions operate, and everything. Gsxr, send yours in for a replacement. If your dealer isn't cooperative, call Edge directly - they'll take your credit card info just in case they don't get yours back, but won't charge anything as long as they do (this is what they offered me, but Con was very accomodating).


Again for everyone in the market, Con had a GREAT price, and really went out of his way to make this right: I ordered Monday, paid for 2 day air, got the Edge (v4.71) & Attitude on Wed. Attitude didn't work - Edge said said the box needed to be a 4.73 (even though they told Con if it had the green plug it would work). Con got me a new Edge box (v4.73) out next day air. Again, same problem, Edge now said it must be the Attitude. AGAIN (!), Con sent out next day air (Sat delivery no less) a new Attitude, and works now. I would highly recommend Con.Edited by: Joe E
 

·
Registered
Joined
·
369 Posts
Discussion Starter #10
Joe, out of curioisty what was the build date on the back of your bad and good attiutedes???
 

·
Registered
Joined
·
611 Posts
Mine says: 9/29/2003
 

·
Registered
Joined
·
267 Posts
I don't remember the old date, but it was sometime in early Sept and version I-1.0. The new one is Sept 22 adn the same version number.
 

·
Registered
Joined
·
16,610 Posts
Mine works 110%. Con treated me right! I was lucky enough to get a good one first time. For anyone looking to buy one, check out Con. The price was too good to be true.
 

·
Registered
Joined
·
611 Posts
I can't believe this @*#T



Today I got my second "ATTITUDE", it was shipped here next day air Saturday delivery. I decided this time around I'll read all the instructions well and take my time. Sure enough everything lights up, but juice levels stays @ 0, 0-60, 1/4 mile, trans defuel, etc DON'T WORK. I can change the juice levels with the attitude, but I have to confirm it with the "PRNP". If I ended up with 2 faulty units in a row, then I think we have a problem here.



Edited by: DIESEL 5
 

·
Registered
Joined
·
369 Posts
Discussion Starter #15
Well my display and buttons mysteriously came to life after plugging and unpluging many times....... HOWEVER it still does not work right, the power levels cannot be changed by using the up and down arrows on the attitude, it just stays at zero. I programmed my juice the old way and can verify it with prnrp and the truck grunts 2 times for level 2 even tought the attitude says ZERO..... half the time the buttons do not work, basically all this attitude is good for right now is a overpriced boost and temperature sensor......... Hope the next one i get works.... This is dissapointing for something that took this long to get released. Mine is a build date 9/29/03





On a 2nd note, my juice dealer is boning me
,
he will not send me a new attitude till i send the juice and attitude i have now back to them first. I told him i wanted to have him put a new attitude in the mail on monday for me and i would put the non working one in the mail on monday back to him basically his response was " if you don't like that policy send all of it back and we will refund your money (plus a 15% restocking fee charge according to the bill of sale..) WTF i waited a month to get this, it don't work and this guy won't send me a new one while mines in transit even thoguh he has all my credit card info.... Wish i had bought from Con's to instead of this BOZO......
 

·
Registered
Joined
·
16,610 Posts
gsxr, I have played around with mine quite a bit. Here is something to try. When you are on the guages screen (the one that displays the guages) press enter REALLY QUICK twice. This will bring you to a new screen that you probably haven't seen before. Something about back down, don't remember exactly. set it to '0' and press enter. Then you might be able to adjust your levels while on the guages screen. I am not sure what it does but if I set mine to 10 for example, it locks my level setting and won't allow me to adjust it. I don't know if it will work for you but it might be worth a try. I don't know what this is supposed to do because it is not documented anywhere and I just stumbled across it by pushing buttons.
 

·
Registered
Joined
·
3,410 Posts
I may be making a purchase in Grand Rapids on Saturday, but just in case I don't How would one get in contact with Con? And I wish he would use a different name! Con just sounds like bad news all the way
 

·
Registered
Joined
·
267 Posts
hdmax said:
I may be making a purchase in Grand Rapids on Saturday, but just in case I don't How would one get in contact with Con? And I wish he would use a different name! Con just sounds like bad news all the way

hdmax, I was planning on buying in GR too, but I got anxious and called Con. I had exhanged phone calls with another vendor, who simply recommended I order online, at which point my mind was made up to order from Con. His price was better than I expect to see in GR - I might be wrong, but it was damned good. I agree about his name - I was nervous too but can personally attest for his service. Good guy.


gsxr, that blows. Like I said above, screw your dealer: Call Edge direct (I talked to Matt, twice I think), and tell them what's up, what you've heard, etc, and see if they'll send you one (asap) while you ship yours back. They'll need a cc number, but they won't charge anything as long as they get yours back.Edited by: Joe E
 

·
Registered
Joined
·
611 Posts
I bought mine from Con, he is great.The problem is edge.
 
1 - 20 of 36 Posts
Top