Diesel Place banner

1 - 13 of 13 Posts

·
Registered
Joined
·
571 Posts
Discussion Starter #1
I just installed an edge w/attitude. Mostly stock other than that.

What level do you edge owners generally drive around at?

I do not plan on using 4 or 5. Will do 2 when towing. If your doing 4 or 5, what other mods do you have?
 

·
LT. Dan
Joined
·
6,817 Posts
level 3/5 all the time. ill switch over to 4 or 5 frim time to time for run.
 

·
Registered
Joined
·
2,362 Posts
I run around on 3 and 2 for towing.

Alison slip is what you have to worry about in 5 and a free flowing exhaust would also help keep the temps down.

I would get a cold air intake to help get some more air into her no matter what level you run. I like the AFE ProGuard 7.
 

·
Registered
Joined
·
64 Posts
I've been running at level 2, but I just got mine a month ago.
 

·
Registered
Joined
·
1,005 Posts
I run level 1, sometimes 2. Occasionally 3. I switch to level 5 for the few occasions for smoking someone. Wheres theres smoke, there is fuel and since daddy doesn't pay my fuel, level 5 is a rareity. I don't race 'cept end of the month to pickup SS chk ~ :) ;)


See sig for mods ~

Shummy ~
 

·
Diesel Master, Formerly goth2o
Joined
·
5,510 Posts
Always on 3. Low boost usually at 5. Definately get a cold air and exhaust so it can breathe. You'll notice quite a difference. I don't use level 4 much or 5 at all. Without a built trans it really doesn't put the power to the ground anyway (not to mention it will cause it to slip and damage it). Mine feels the most powerful on level three with my set up.
 

·
Registered
Joined
·
1,366 Posts
Don't waste your $$$ on the CAI, save it for lift pumps and trans upgrades.
 

·
Registered
Joined
·
2,213 Posts
The trans should last a while on any level with the edge. it constantly monitors slip, and backs itself out if it sees any. granted, it will eventually eat it (the trans), so do start saving your cash for upgradeing or rebuilding down the road...
 

·
Registered
Joined
·
239 Posts
I have limped mine 3 times in 3/3 so unless you upgrade the tranny now I wouldn't run it on more than 2. Info I have gotten is that once you limp it it limps easier the next time and it damages the cluthes. I am currently attempting to save $ for the tranny upgrade. I have run it on 5 and did the performance test and all that but limped it while at highway speed and rolling into the throttle to pass, I wasn't hammering the pedal or anything like that. I'ts cheaper now to upgrade rather than later. Edge only monitors slip when the converter is locked so it will power down when slip observed when converter is locked. However, it will not power down if the converter is not locked and you get slip (info straight from Edge). . So that is how I limped it, 5th gear, no converter lock, no slip monitored, to much torque, no power down..........BAM limp mode.
 

·
Registered
Joined
·
199 Posts
I've run mine on 4/5 just driving and 2/5 or 3/5 towing depending on the load. Truck is totally stock other than edge/att and has been running this combo for almost 90,000 miles. So far, it has never slipped the trans, but the trans is getting weaker (flairs more between shifts) so if I keep my truck much longer I will be upgrading the trans.
 

·
Registered
Joined
·
2,213 Posts
Sulley;1602866; said:
...Edge only monitors slip when the converter is locked so it will power down when slip observed when converter is locked. However, it will not power down if the converter is not locked and you get slip (info straight from Edge). . So that is how I limped it, 5th gear, no converter lock, no slip monitored, to much torque, no power down..........BAM limp mode.
Yeah, now that I think about it, you're right Sully. I think that the reason my old man's truck has lived so long with the edge installed is because he is just that...an old man...even so, he still plays from time to time. if your carefull with it, it should live a fair long time, but the time will come that you'll need a rebuild. or just beef it before the damage occures.
 

·
Registered
Joined
·
239 Posts
MikeL advises that most likely the C3 clutch is damaged (possibly C2 & C4 as well) when you limp it. I took mine to dealor today (that installed Edge), they ofcourse checked the codes and drained the fluid. They said no color change in fluid....Blah.....Blah and so on so they think it was the Edge causing the code (no crap, can you say to much torque in 5th gear) so want to send it back to get it checked out. I advised them of all the info I had gathered (on this forum from all the knowledgeable people) and exactly what the issue was but they just don't understand I guess. They unplugged it and I didn't get to talk with them since I picked it up after they closed. I guess I will send Edge back next month to get the new updates. What I thought we had agreed upon was a tear down and inspection of the clutches and replacement if damaged but I guess they misunderstood. I guess I will just have to pay for the upgrades when I can afford it but was hoping that I wouldn't have to pay for the clutch replacement (if need be). They advised me they would warranty evrything but if they don't understand I guess it's hard.
 

·
Registered
Joined
·
10 Posts
scott
if they say they will warranty it turn that thing up to 5/5 and turn the defuel off shouldn't take to long then. If it comes in on a flatbed they will have to tear it down.
 
1 - 13 of 13 Posts
Top