Diesel Place banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5,495 Posts
Discussion Starter #1
I posted before in the Ask the Tech's section but it is now closed. I have the randomly occuring ABS Brake Light and dinging + Service Brake System on the DIC. So far I have replaced the rear speed sensor and had the EBCM upgraded to the new software per TSB. I am still getting the lights and bells + the DIC warning. Today I noticed that when the warning came up that the speedometer was erradic and flucuated 2-3 mph whild on criuse. You could actually feel a change in speed. When I replaced the old speed sensor with the new one I could see on the bottome of the old one where it had a wear groove from something coming into contact with it. I thought it was just a magnetic triggering switch and didn't actually touch anything. Anymore Idea's on what to check next? Thanks HDS
 

·
Registered
Joined
·
12,262 Posts
Since regular members that could assist answered the question along with the GM Techs. So it was felt that there was no point to have a separate area.

Moving to Drivetrain


Good luck with your problem
 

·
Registered
Joined
·
5,495 Posts
Discussion Starter #3
OK, here's an update. Hope your's is a lot more simple. When I first replaced the Rear speed sensor I noticed that something had actually been coming into contact with the bottom of the sensor as a wear grove had developed there. Today I crawled under it and took out the new sensor and looked at it. It too now had a grove wore in it. Something was moving around inside of the transfer case enough to allow whatever it is in there that triggers the sensor to come into contact with it. I grabed the front of the driveline where it connects with the tailshaft and there is about 1/8th inch side to side movement. So it looks like some bearing or bushing inside the transfer case is the cause of the faulty sensor reading. Will know more when it's tore down.
 
1 - 3 of 3 Posts
Top