Diesel Place banner
1 - 6 of 6 Posts

·
Registered
Joined
·
353 Posts
Discussion Starter · #1 ·
2001 Chevy ECSB DA. Stock with no aftermarket adds.

DOA. Truck had some NASTY fuel put in the tank. It wasn't fit to use to burn a brush pile. DUMB! DUMB! Customer states prior to hauling in tank was dropped and bad fuel was removed along with going through a couple filters. Truck was running, died and never would restart. Customer claims engine will fire on ether and then die.

1) We changed fuel filter. Seemed like a faint gasoline smell when we dumped the filter.

2) Fuel Rail Pressure Sensor - good

3) Injection Pump replaced per Tech Assist

4) Low side fuel delivery good, clean, and no leaks

5) High side Rail pressure is 300 psi while cranking. (Spec is 1450 psi for injectors to fire.)

6) Fuel return of 20ml during 15 sec crank

Any ideas? ECM? Tech Assist said order another injection pump and install which we did.
 

·
Registered
Joined
·
353 Posts
Discussion Starter · #3 ·
Yeah, I know. Wayyy low.

2" of vac
 

·
Registered
Joined
·
692 Posts
20ml seems high I have seen 12-16. not 20. that tells me each injector is flowing an average of 5 ml. seems high.
check injectors.
 

·
Registered
Joined
·
353 Posts
Discussion Starter · #6 ·
20ml seems high I have seen 12-16. not 20. that tells me each injector is flowing an average of 5 ml. seems high.
check injectors.
We haven't ever seen 20ml either. Didn't know exactly the internals of these injectors and wonder if we had a problem with some in this truck. We've put quite a few in 2001's and 2002's along with a few 2003's and only 2 or 3 2004's.
 
1 - 6 of 6 Posts
Top