Diesel Place banner

1 - 8 of 8 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
We just bought a used 3500 6.5 Turbo Diesel, and had to replace the PMD right off the bat. This solved our problems for a day or so. Now we've got hesitation so we used the code reader after the engine light came on. The code indicated P0238, which is Turbocharger Boost Sensor Circuit High Voltage. Is there anything we can do or is this a serious problem?

Thanks!

DTC SearchDTC Search
 

·
Registered
Joined
·
3,752 Posts
Try using the search button on the forum....all kinds of discussion on that particular code in the past.....
 

·
Registered
Joined
·
3,222 Posts
Check for wire chaffing to the boost sensor mounted on the intake manifold.
 

·
Registered
Joined
·
6,945 Posts
Check if the connector is plugged in, and the wiring for frayed, broken.

If ok, could be the sensor is failed
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
I checked the photo reference in the FAQ section to find the location of the sensor, but did not see a pic of it. Is there a photo reference for locating sensors?

Thanks!
 

·
Registered
Joined
·
8,014 Posts
diesel truckin;1600590; said:
I checked the photo reference in the FAQ section to find the location of the sensor, but did not see a pic of it. Is there a photo reference for locating sensors?

Thanks!

It is there I just edited it to clear it up some see thread 1 in pictures hyperlink
 

Attachments

·
Registered
Joined
·
20 Posts
Discussion Starter #7
I see it now, Thanks....
 

·
Registered
Joined
·
20 Posts
Discussion Starter #8
Well, we got the new sensor installed and it works just great. No more hesitation or codes. We were having fluctuations in power when idling also before this, and that has stopped too... Amazing what a big difference a little part like that makes..

Thanks
 
1 - 8 of 8 Posts
Top