Diesel Place banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2,362 Posts
Discussion Starter #1
I bought a new pair of Husky Liners for the truck and noticed that I could not get the pedal to get the engine all the way open(full throttle). I got home and started looking at it and I noticed that the bracket that holds the accelerator had made a mark in the rug! I know I drive fasts but in no means do I drive around at full throttle to make a permanent mark in the rug!


What I am asking is....


1. Is this normal....does everyones accelerator bracket make a mark on the rug?


2. Is there a way to adjust this witout having to cut my rug?


I have noticed that over the past two weeks the truck has really been dogging.....it does not have the power it once did when I first bought it. The Truck only has 3500 miles on it. It has also been cold in the mid west but I really do not think this would have anything to do with it. I also put a brand new AFE on a month ago. I am getting ready to bring it to the shop to see what the deal is. Today my wife even made a comment about the lack power....she said it felt like the old Power Stroke!
 

·
Registered
Joined
·
7,190 Posts
I have Husky's in mine, using the Preator to check it, I get full pedal travel as far as the Drive by wire is concerned.


I see 99.8-100%


I too thought I was losing travel, but no mechanical link or cable connects you to the motor, just a resistance value



Kinda weird at first, but it works.......so don't sweat it.





T
NYEdited by: GMC-2002-Dmax
 

·
Registered
Joined
·
463 Posts
NoWake200 said:
1. Is this normal....does everyones accelerator bracket make a mark on the rug?




I'll bet Mac's does!















Kevin
 

·
Registered
Joined
·
464 Posts
NoWake,


I just got some husky mats this Christmas and I agree it feels as if I can't get 100% throttle either. If I really stand on it, it feels like it is getting full throttle, but under normal driving I definately feels some interference. No problem with my carpet though. I am planning on getting a predator soon so Ill be able to see how much throttle I can apply before resistence is felt. I think I will remove my mats for racing just to go easier on my leg.
Other than that I love the mats.


Jason
 

·
Registered
Joined
·
2,362 Posts
Discussion Starter #5
I do not get it.



It just feels wrong.....I guess there is no adjustment for it.
 

·
Registered
Joined
·
9,300 Posts
Yeah i only get 99.7%. I knew there was a reason that Z06 beat me the other day.
 

·
Registered
Joined
·
10 Posts
NoWake2000-


Regarding your lack of power. My truck did the same thing at about the same mileage as yours. It took about 1k miles for it to come out of it's funk. I'm not sure what caused it. It's almost like it de-tuned it's self durring break in, or perhaps more likeley, it learned how to run the way I wanted it to! You could change your fuel filter, or take it to the dealer if youre realy concerned. I was kinda freeked about it too, but like I said it came out of it with no problems!
 

·
Registered
Joined
·
2,362 Posts
Discussion Starter #8
I noticed that when I stoped using Stanadyne additive the power came back. I went with three fillups using Stanadyne, each fillup was at a differnet fuel stop and different states. And the last fill was on empty and noticed the change right away.


But then again maybe it is all part of the break in.


I guess I should try using the Stanadyne again and see what happens.
 

·
Registered
Joined
·
994 Posts
In your signature you indicate you have the Juice/Attitude combo. If I remember correctly (this is always a ? mark!!), the Attitude can display the %Throttle that is applied. You may want to set the Attitude display up to show this. If you never get to 100%, then you have a problem. If you get 100%, then is there more to gain?
 

·
Registered
Joined
·
2,362 Posts
Discussion Starter #10
The Juice/Attitude is on my 'want list'. Someday I'll know were my % of throttle is.
 
1 - 10 of 10 Posts
Top