Diesel Place banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey Yall,
Ive been this forum on and off for sometime, but Ive recently developed a problem with my trucks electrical system that has stumped me.


I have a 1996 Chevrolet K1500 wiith 6.5 TD.

My AC compressor went bad so I went and bought a refurbished unit at my local store. (1st mistake, should have bought new). Well I got it back to where a was working on the truck and we installed the compressor, replaced condenser, vacuumed the lines, and added PAG and R134. Well the AC worked GREAT for about 2 days and then the clutch seized and locked up as I was driving down the highway. The compressor got very hot and internal parts of the ac clutch melted. (it smelt awful). Well after removing it, I took it immediately back where it was purchased. They took it apart and said it was a defect in the compressor and gave me another compressor again refurbished. Well I went and reinstalled, vacced, everything all over again, but this time the compressor will not turn on. I even tried jumping the high power sensor on passenger side by the condenser to jump the compressor on. Nothing I could do would get ac compressor to turn on. Now I have checked and double checked everything and i have found that there is no power to the high pressure compressor switch/plug on the back of the compressor itself , there is also no power going to the clutch plug/on the top of the compressor by the pulley. There is power however going to the high pressure switch by the condenser on the passenger side, and there is power going to low pressure switch. I replaced the AC relay under the hood, but it had no effect. I then checked all of the connections of the 4 prong ac relay in the fuse box, and there is power missing to half of the AC relay prongs.

What could cause the AC relay to not get power?\

Also I dont know if this is related but sure for about 6 months the horn would only work intermittently, now it also does not seem to work...not if relay is bad havent replaced/checked yet.


Thank you for any help you can give me!

-Cotton
 

·
Administrator
Joined
·
15,720 Posts
Hey Yall,
Ive been this forum on and off for sometime, but Ive recently developed a problem with my trucks electrical system that has stumped me.


I have a 1996 Chevrolet K1500 wiith 6.5 TD.

My AC compressor went bad so I went and bought a refurbished unit at my local store. (1st mistake, should have bought new). Well I got it back to where a was working on the truck and we installed the compressor, replaced condenser, vacuumed the lines, and added PAG and R134. Well the AC worked GREAT for about 2 days and then the clutch seized and locked up as I was driving down the highway. The compressor got very hot and internal parts of the ac clutch melted. (it smelt awful). Well after removing it, I took it immediately back where it was purchased. They took it apart and said it was a defect in the compressor and gave me another compressor again refurbished. Well I went and reinstalled, vacced, everything all over again, but this time the compressor will not turn on. I even tried jumping the high power sensor on passenger side by the condenser to jump the compressor on. Nothing I could do would get ac compressor to turn on. Now I have checked and double checked everything and i have found that there is no power to the high pressure compressor switch/plug on the back of the compressor itself , there is also no power going to the clutch plug/on the top of the compressor by the pulley. There is power however going to the high pressure switch by the condenser on the passenger side, and there is power going to low pressure switch. I replaced the AC relay under the hood, but it had no effect. I then checked all of the connections of the 4 prong ac relay in the fuse box, and there is power missing to half of the AC relay prongs.

What could cause the AC relay to not get power?\

Also I dont know if this is related but sure for about 6 months the horn would only work intermittently, now it also does not seem to work...not if relay is bad havent replaced/checked yet.


Thank you for any help you can give me!

-Cotton

Go through All Grounds using the reference thread here:http://www.dieselplace.com/forum/63-gm-diesel-engines/21-6-5l-diesel-engine/163087-grounds-grounds-grounds-importance-good-grounds.html
 
1 - 2 of 2 Posts
Top