Diesel Place banner

1 - 4 of 4 Posts

·
Registered
Joined
·
16,610 Posts
Discussion Starter #1
Hi Eric. A couple quick questions. Not sure if you will be able to help or not.

My buddy has a 97 Chev K1500 305, auto. He has been complaining about poor fuel milage among a few other problems. I hooked up my scanner and got 2 codes.


1- P0172 Fuel system too rich bank 1.
2- P0147 02 heater CKT Bank 1 sensor 3.


Any guesses on what to look for?


He also has problems where sometimes his speedo doesn't work then all the sudden starts working. Odo does work when speedo doesn't. Have you seen this before? I was thinking either poor contacts on the through pins where the speedp drive connects to the board in the IC? Possibly poor ground on IC?





He also said that today he went out to start his truck and the clock was at 1:00 and it was 5:30. Also the radio was Off when he knows he left it on. I haven't looked to see if the ground point is the same as the IC yet. Have you seen this before?


I thought I would ask these first before I go looking because these trucks seem to have lots of the same problems so I thought maybe you have seen this before.



Thanks for all your help. I will have to get some snap on gift certs you way :) I'd much rather take you out for a steak but you need to move closer to me
 

·
Registered
Joined
·
8,014 Posts
In 98 GM Manual P0172 is Fuel trim system Rich Bank 1


PO147 heater O2 sensor performance Bank 1 sensor 3 my guess is bad O2 sensor #3 making him run rich


That said with the other problems you mention , looks like grounding issues are high on list as well as poor connections on them (aka grounds) will set these codes as well according to the manual don't know which is 1st chicken & egg situation I guess check grounds and then O2 sensors


I apologize for posting 1st Eric I know this is your forum, but it is the weekend and I did not know if you were working it, and had time or had access to the manuals, my 98 book was literally in my lap at the time I saw this thread so I looked it up while in it.


Years back in my 90 GM 4.3L gassser found a bad main ground engine to frame behind block by starter broken, fixed it with # 4 double ring lug to frame and alternator mounting stud, out in open where I could monitor it








Edited by: Turbine Doc
 

·
Registered
Joined
·
16,610 Posts
Discussion Starter #3
Thanks for confirming my conclusions Turbine Doc. It's like you are reading my mind
 

·
Registered
Joined
·
11,646 Posts
T-doc, no need to apologize.. Max, I agree with him, I would start by replacing the 02 sensor. Position no 3 is gonna be post cat one on the drivers side. Clear the codes and go from there.


Eric
 
1 - 4 of 4 Posts
Top