Diesel Place banner
1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
I’m pulling codes 82,38,36 and 87. It runs and drives good and the trans was gone thro before I got it, but shifts really hard into 2nd and I only get one tcc lockup per drive, as stupid as that sounds. Start it, go drive, goes through all gears plus tcc lock, once I slow down and take off again it will not run the tcc again until I shut down and restart.

I don’t get a service engine light until I get to 65mph. I’ve been through all my grounds, cleaned and added some with no change. Am I possibly looking at a bad solenoid? I need a little direction, not sure where else to look at.
 

·
Administrator
Joined
·
20,698 Posts
I’m pulling codes 82,38,36 and 87. It runs and drives good and the trans was gone thro before I got it, but shifts really hard into 2nd and I only get one tcc lockup per drive, as stupid as that sounds. Start it, go drive, goes through all gears plus tcc lock, once I slow down and take off again it will not run the tcc again until I shut down and restart.

I don’t get a service engine light until I get to 65mph. I’ve been through all my grounds, cleaned and added some with no change. Am I possibly looking at a bad solenoid? I need a little direction, not sure where else to look at.
Pull the connector on the side of the trans to look for moisture or ATF fluid inside
 
  • Like
Reactions: dieselolds

·
Registered
Joined
·
3,795 Posts
Code 37 Brake switch on. Will keep the TC from locking. also may cause the 87 gear ratio error. even tho your brake lights may work the brake switch can still be bad. Also as OK said above check he main trans connection. If clean and dry. then the 1-2 solenoid ( code 82) may be going out.
 
  • Like
Reactions: 96C3500

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
I’ve replaced the brake switch recently with no change. I even tried unhooking the plug to the switch just for grins and still the same.
 

·
Registered
Joined
·
55 Posts
I’m having a list of issues.
Part of it was a brake controller wired incorrectly to the brake switch
I’m about to follow the wires the best I can
Food for thought
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
I’m having a list of issues.
Part of it was a brake controller wired incorrectly to the brake switch
I’m about to follow the wires the best I can
Food for thought
It’s worth looking at, never thought to mess with it.
 

·
Registered
Joined
·
4,400 Posts
Connect scan tool. drive until no lock up. Look at input and output speeds and fluid temp. ECM seeing low fluid temp can cause no lock up. Take input and output sensors out to clean off any metal filings that can "foul" the sensor.
 
  • Like
Reactions: OkDually

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
Connect scan tool. drive until no lock up. Look at input and output speeds and fluid temp. ECM seeing low fluid temp can cause no lock up. Take input and output sensors out to clean off any metal filings that can "foul" the sensor.
Does a 94 actually have live data? I don’t have a scan tool that will do that on obd1 anyway.
 
1 - 8 of 8 Posts
Top