Diesel Place banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys I've got a first gen 93 d Duramax turbo diesel it's in a tow truck I've been having problems with it shifting from third to overdrive and it's hard shifting in the first three years I reset the computer I'm hooking the batteries it seems to run okay for a few minutes shifts through the gears and then goes back to only one through three it's got a l480e trans I pulled the computer out of it and looked and it's I have the black wire I believe it says B3 looks like it has back fed or heated heated up and melted the connector do I need a new computer trying to figure out what that black solid black wire I believe it's it's 3C is
 

·
Administrator
Joined
·
19,695 Posts
Welcome to DieselPlace

The Duramax diesel engine started in 2001. Your 93' should be a 6.5L
Please tell us a little more about the tow truck ( Make, Model ) and list any mods
(y)
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Okay so I just bought it it's registered as a 93 Chevy Cheyenne cab it's got a 6.5 turbo diesel engine a new one the owner said it had been the previous one is blown up they put this new one in I guess I should get the the case number to see exactly what year it is and go from there other than that it's got a dynamic bed wheel lift and boom it's got electric hydraulic pump electric switchesit runs and drives great it's just having that shifting issue it only goes to 3rd gear won't hit 4th and overdrive
 

·
Registered
Joined
·
3,638 Posts
Have you tried pulling trouble codes? That would help a lot. With out any codes. All I can do is guess that it may be the 3-4 shift solenoid. There can be other issues as well.
 
  • Like
Reactions: OkDually

·
Registered
Joined
·
4,392 Posts
It was common for the ECMs in the 92-93 to fail. I'd get a different used one from a salvage yard. car-part.com
 

·
Registered
Joined
·
4,440 Posts
"C3" on the 32 pin conn. is black and is engine/batt ground.
 
  • Like
Reactions: OkDually

·
Registered
Joined
·
750 Posts
It was common for the ECMs in the 92-93 to fail. I'd get a different used one from a salvage yard. car-part.com
Just a small thing, but I believe it's a "TCM" on the 92-93 models. No engine computers on those years. Just transmission control modules.
 

·
Registered
Joined
·
186 Posts
Okay so I just bought it it's registered as a 93 Chevy Cheyenne cab it's got a 6.5 turbo diesel engine a new one the owner said it had been the previous one is blown up they put this new one in I guess I should get the the case number to see exactly what year it is and go from there other than that it's got a dynamic bed wheel lift and boom it's got electric hydraulic pump electric switchesit runs and drives great it's just having that shifting issue it only goes to 3rd gear won't hit 4th and overdrive
As another user posted it only has a TCM. The first thing you want to do is adjust the TPS. If that doesn't work replace it, Unlikely anything is wrong with the TCM or it wouldn't be commanding the trans to shift. I have a 93 and use to be a line mechanic for the Chevy House. I bought my 3500 for $500. My kind of truck. Rebuilt everything. Hopefully after my neck surgery I'll be able to install a new or rebuilt engine.
 

·
Registered
Joined
·
750 Posts
The burnt connection definitely needs fixing. I did have your exact same symptoms on my '93 and it was an ignition switch with corroded worn contacts.
 
1 - 9 of 9 Posts
Top