Diesel Place banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Thanks in advance, hope some one can give me some ideas.

Gasser 91 GMC 4wd Sierra HD (8600 GVW) sometimes will only drive in 2nd gear (reverse OK). I hope you forgive me posting a gasser question, I also have a diesel, but it is just fine - hope that gets me off the hook.

History:
Started down shifting a bit jerky 2nd to 1st (for several months in summer and only after it warmed up, downshifted smoothly while still cold)

This winter in north east started lighting up SES light.

When SES light comes on, shifting into drive will result in 2nd gear only if I turn the engine off, wait some a random amount of time sometimes it will return to normal. But when light is on and stuck in 2nd it has not popped into 3rd if I drive over bumps, wot or start stop traffic)

Took it to trans shop when SES light was on, no code could be scanned out with shop scan tool.

Tried the blink method myself (jumper 2 pins on scan connector), same results only a pair of 12s (pause-blink-pause-blink-blink-pause & repeat - diagnostic code indictor, nothing in middle)
Local trans shop mechanic did not want to guess what was wrong & did not want to do random replacements (though when I pressed him he said the solenoids worth a guess, if I wanted to roll the dice on $170)

Standard service performed not too long ago (gear oil & filter), trans oil looks & smells ok. Oh yeah, speedo works fine.

Anyone with early K2500 4l80e experience please share your ideas on this puzzle.

thx
 

·
Registered
Joined
·
55 Posts
You can do the solenoid swap yourself. All the solenoids together are about $100. I had a similar problem, would only start off in 2nd. Took it to a Trans shop(friend) he put a scanner on it we rode around for a half hour. He said it was the ECM. I got a rebuilt one from the dealer$155, didn't change a thing. Talked to his trans rebuilder, he said solenoids. I replaced them all(4) and oil-filter. That was 60,000 miles ago. The main computer tells the trans to shift it doesn't get feedback if it does or not. Your speed sensor could be part of the problem, easy replacement $20. If you can do the work, these are cheap fix.
 

·
Registered
Joined
·
21 Posts
How many miles on your 4L80E? I have experienced it all with my '91 K-2500 (8600 GVW) w/ a 6.2L at 166K. I am on my 3rd replacement and I guess snow plowing has been hard on them. It is strange you have no trouble codes which to my way of thinking it is more of a mechanical problem vs. electronic. I have had to replace my TPS (throttle position sensor) before but usually that triggers a code. I know on a gas engine you have a PCM (computer) that manages both the engine and tranny. On the diesels there is only a TCM which is only used to control the tranny so it makes life a little easier for troubleshooting.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Thanks to all for suggestions. Looks like 4l80e is fine, the 2nd gear only behavior is caused by ECM forcing limp home mode and I have to figure out what is causing the check engine light with no codes.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Forgot to add that I noticed that when the Check engine will go on while parked, Idle will be higher than normal, which points to leak - intermittent one? (in addition to the 4l80e going into limp home mode).

did some sensor checking:

TCS is ~400 ohms (legal range for coolant temp sensor).
TPS seems ok varies from 1K ohm to 4.5K ohms on a 5.6K full range (should be equivalent to a 0.88V to 3.98V voltage divider pot)
IAC ohms out at 30 or so ohms on both windings
Vacuum lines look fine, don't feel or hear leaks

Will chek O2 sensor when I find it, docs say firewall side of exhaust manifold (but nothing sticks out when I looked)
 

·
Registered
Joined
·
12 Posts
If it is still broken and you have eliminated the solonoids here's something I have seen twice in G vans with a smallblock early 90's... You might be stuck in third, not second. The direct clutch cushion spring in the bottom of the direct drum breaks and then jams direct into the on position permanently. The vehicle will back and have a dragging sort of 2nd or 3rd gear start and thats all, no shifts. The ecm will sometimes set a solonoid code maybe.
 
1 - 8 of 8 Posts
Top