Diesel Place banner
Status
Not open for further replies.
1 - 5 of 5 Posts

· Registered
Joined
·
76 Posts
Discussion Starter · #1 ·
95 6.5l has a quad star tune exhuast air ontake upper intake and 2.5 crossover pipe. Drove it home one day sat for 2 days went to start it and the gp didn't cycle and wouldn't start. Towed it to the shop got a new pmd new lift pump and a tank sending unit and a new ops. It starts after awhile of cranking runs fine until it gets up to 160f then dies and wont start again. today it started up again but with a service engine light. It stumbled a little bit when I gave it throttle then died. I have made othere forums but no one has really said much other then stuff I already did.
 

· Registered
Joined
·
76 Posts
Discussion Starter · #2 ·
I also plugged in the old pmd and it did the same thing it did before. I tried reading codes and got nothing idk maybe I was doing it wrong?.
 

· Registered
1995 GMC Suburban
Joined
·
18,511 Posts
Is the old PMD tested and working on your truck before?
 

· Registered
Joined
·
76 Posts
Discussion Starter · #4 ·
It gets fuel to the filter and there is no air. If I open the bleeder up in the filter it squirts out fuel. I already ordered a new pmd and if that doesn't fix it then idk what next. I unplugged the new pmd and put it in the old on and the same thing happend. Cranks then tries to fire then dies let it sit and then fires up. I also ordered a resistor with the pmd from kb diesel performance
 

· Administrator
Joined
·
22,221 Posts
Duplicated Thread closed
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top