Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
I have a 98 6.5 i took off the upper intake to get ready to install my intercooler.After i figured out i am gonna half to cut and reweld one of the pipes i put it all back together. Also i did install egt gauge. The truck started right up ran for a minute then stalled. Now it sounds like there is no fuel it just turns over and won't fire. AAny help on what i can check is appreciated Thanks Kurt
 

·
Registered
Joined
·
11,646 Posts
Hmm, first let me state that I am by no means a 6.5 tech.. my knowledge on them is VERY limited.


If it started and died, chances are it lost prime, crack an injector line and crank till you get fuel, then tighten.. I dont think you even need to touch them to remove intake. You say upper? just the center section? or did you remove the actual intake? I would have to say a prime issue but am open to other suggestions from members





Eric
 

·
Registered
Joined
·
47 Posts
Discussion Starter #3
Hi there Eric, I took off just the upper intake with egr.I must of lost prime like you said.I put a rag around my air nozzle and pressurized my fuel tank the truck started then died. i went and bought a new fuel filter put it together and purged it again and it is running,rough but running.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #5
Is the lift pump the one under the truck?Also i realized stupid me hit the air vent on the top of the fuel filter and that must be how i lost pressure! I least i learned that lesson the not so hard way. thanks again Kurt
 
1 - 5 of 5 Posts
Top