Diesel Place banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
The Diagnostic Checklist:
Please fill out to best of your knowledge.



1. Describe the problem you are having in detail:
The truck is not pulling vacuum through the solenoid. The wastegate isn't being activated and I'm not getting near enough power out of the truck. Black thick smoke on harder acceleration.
This all started with P0236 Code being thrown.
I replaced the vacuum pump with a new unit. Getting good vacuum from it
I replaced the Wastegate Solenoid with a new unit from the Chevrolet Dealership
I checked the PMC grounds and they are good
I checked and the wastegate solenoid connector is getting 13.6 volts through it at idle which seems high but it is getting voltage
There is no vacuum going from the solenoid to the wastegate actuator.
If I wire the wastegate arm up I can hear the turbo spool and build boost etc.
Very frustrated with it at this point

2. Year of truck/engine.
1998
3. Odometer reading (indicate miles or kilometers).
304k miles
4. Indicate the model number on the Injection pump (starts DS4 or DB2......).
5. Indicate if you know if it’s a 1500, 2500, 2500HD, 3500, 3500HD.
3500
6. Do you have an EGR on the engine? (An F or an S engine code 8th VIN digit)
No
7. Air Filter condition (visual check).
Clean
8. Fuel filter condition (freshly changed, mileage since changed).
Freshly changed
9. Location of PMD/FSD? (ex. on pump/remote over intake, behind bumper).
Remote
9a. If remote mounted, describe wiring harness (homemade or purchased from which vendor).
Unknown, looks professionally made

9b. Indicate the location and condition of the FSD/IP grounding wire.
10. Outside Temperature (C or F). _ °
90F

11. Service Engine Light while running?- on/off/intermittent
Intermittent. Code P0236
11a. Service Engine light does glow during start/cranking/bulb check: Yes/No
Yes
12.Have you scanned for engine codes? Yes/No
Yes
12a. List exact results on engine codes.
P0236
13. Condition of Battery terminals (removed, cleaned and tightened).
Good, New battery cables
14. Known condition and age of Batteries.
March of this year
14a. Are batteries a matched set of same age?
Yes
15. Condition of Major Grounds (removed, cleaned and tightened)
Removed, cleaned, tightened
15a Have the batteries been individually load tested?
No

16. Does engine crank, or "turn over"?
Yes
16a. Does engine start and run?
Yes
17. If engine does not start- Crack injector line: do you have fuel? Yes/No\
NA
18. Does your Wait To Start light come on?
Yes
18a.Number of seconds WTS light is lit.
3-4
19. Engine Cranking speed (if you have an accurate tachometer).
Normal
20. Are you experiencing Stalling?
No
20a. Describe the event (upon startup only, down the road, hit a bump, etc...)
All speeds
20b. Do you notice loss of dash or instruments?
No
21. Check turbo inlet and air filter for obstructions.
None
22. In a no-hot start, pour a bottle of room-temp water on the injection pump. Does it start now?
NA
23. Lift pump test - Describe results.
NA

24. Upon cold start, does the radiator hose get hard quickly? Yes/No
Yes
25. Upon cold start, do you have excessive white smoke? Yes/No
No
26. Do you have excessive cranking time before the engine starts? Yes/No
No
27. Have you used the block heater? Does it affect engine starting? (only try for starting problems).
\No
28. Are all glow plugs in proper working order?
Yes

29. During hard acceleration, do you have excessive black smoke? Yes/No
Yes
30. Do you have any unusual exhaust smoke issues?

31. Turbo check out - Pass/Fail
Turbo works when wastegate wired up

32. Indicate fuel that you are using: Bio-Diesel, #2 Diesel, SVO/WVO, other
Diesel
32a. If running Veggie Oil fuel setup, indicate details of your conversion (homemade or packaged system).
NA
33. Are you using any fuel additives? If so, please list.
No
34. Upon unscrewing fuel cap, do you have a large vacuum formed in the tank? Yes/No
Some depending on temp
35. Do you have any service history available that might pertain to the problem you are having?
No
36. Please indicate any modifications to the vehicle that might help us diagnose better.
 

·
Administrator
Joined
·
16,326 Posts
Welcome to DieselPlace

Inspect every inch of your vacuum lines. If you have the OEM plastic lines I recommend that you replace them with rubber line.
The OEM plastic becomes brittle junk with heat/age.
Next, remove the Wastegate solenoid and spray a shot of WD 40 into the vac. end of the solenoid and give it a few light taps to free the internals.
The solenoids have been known to stick out of the box.
Inspect every inch of your exhaust ( pre-turbo) including crossover. If you have any exhaust leaks you will have a loss of boost and black smoke.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thank you for the advice OKDually. I should have mentioned I also put new rubber vac lines on between the pump and wastegate solenoid. Also new rubber line between the Solenoid and wastegate.

I went out and sprayed WD40 into it and banged it a lot. Probably abused it. No dice, still no vacuum coming out of the solenoid.

Thanks!
Richard
 

·
Registered
1995 GMC Suburban
Joined
·
17,829 Posts
There is electrical connector to the solenoid, did you check if there is any voltage when engine is running?
I am not sure how much, though.
Glagulator probably can give you a way to do electrical test.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
JMJNet I did, it tests 13.6 Volts across the two pins with the engine at idle.

Thanks!
Richard
 

·
Administrator
Joined
·
16,326 Posts
Thank you for the advice OKDually. I should have mentioned I also put new rubber vac lines on between the pump and wastegate solenoid. Also new rubber line between the Solenoid and wastegate.

I went out and sprayed WD40 into it and banged it a lot. Probably abused it. No dice, still no vacuum coming out of the solenoid.

Thanks!
Richard
If you have voltage to the solenoid, sufficient vacuum to the solenoid but nothing from the solenoid to the turbo then you have a dud solenoid from the dealer.
Try replacing the Solenoid (AC/Delco Brand only!)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Ok will do, thank you. Hopefully the dealership takes it back. If this doesn't fix it I'll just order a turbo master and be done with it.
 
1 - 7 of 7 Posts
Top