Diesel Place banner

1 - 13 of 13 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1
i know this has been discussed before but i was not sure if some knows more about it now. picked truck up from dealer they just finished injector install. drove home everything ok, shut truck off started it again and service 4wd light blinked for a couple of seconds. started afew more times and the same thing happened. let it sit for a few hours started it and no light??? going to get it scaned tomorrow. any ideas 2001ext cab 80k
 

·
Registered
Joined
·
52 Posts
Had this happen on my 2002. The stealer replaced the 4wd switch twice and the dash cluster once and still had the "service 4wd" alert occasionally. I had the transfer case serviced and, finally accepted the intermittant problem but, it hasn't came on in about a year. Who knows whats going on.
Richard
 

·
Registered
Joined
·
115 Posts
Can anyone help me out here with this same topic? :help2: I had read a short while back on this site about a fella who had his truck go into 4wd low while cruising down the highway about 60. Now a friend of mine had his "service 4wd" indicator light come on and stealer couldn't find any problem. Seemed to me that this fella had a similar problem before his jumped into 4-low. I have searched and searched on this site and can't find the post.

Any direction with this would be appreciated.
 

·
Registered
Joined
·
35 Posts
most common for the intermittent 4wd light and intermittent shift to low concern was t-case mode position sensor in t-case actuator..also could be ground issue at frame at a-pillar body mount
 

·
Registered
Joined
·
1,458 Posts
I had this issue on my 05 gasser and it was an encoder motor. Which they didn't replace under warranty. It was $550 for the stupid thing, that had been used about 8 times in 12 months. Not a good setup. I would much rather have a pull shifter.
Check the encoder motor. That might be your culprit.
 

·
Registered
Joined
·
370 Posts
I have had the encoder motor wiring harness go out. The stealer told me the encoder motor was bad, so I swapped it out (I had 2 of the same trucks). 4x4 still did not work. Dug deeper into the problem to find the wiring harness between the TC and TCCM was run too close to the exhaust and melted thru about half of the wires.

...$5 and a few hours later my problem was solved. They are so quick to replace the encoder motor. I know if I had the work done they would have told me something like, "Your encoder motor shorted out and took the wiring harness with it." Yea right, like the wiring harness will give b4 the control module:rant:
 

·
Registered
Joined
·
89 Posts
Discussion Starter #7
Well I Had Mine To The Dealer And They Can Not Find The Problem. They Said That It Did Not Throw Any Codes None. They Said That On Newer Trucks They Could Reflash Them To Take Care Of The Problem, But Not On Mine. They Said They Dont Know What It Is
 

·
Registered
Joined
·
373 Posts
steelhead1268, what year is your truck?
my light has flashed a few times but everything work fine. havent had a single problem. (knock on wood) and i have a 2002, was wondering if it needed to be reflashed or if it could be?
thanks
 

·
Registered
Joined
·
11 Posts
I have an 02 that had the service 4wd light come on.I had the 4wd push buttons replaced along with the 4wd ecm inside the dash and it hasnt come on yet
 

·
Registered
Joined
·
16 Posts
I have an 04 (LB7) that had the Service 4wd light come on. The dealer replaced the front 4wd actuator because it was throwing codes. After it was replaced the Service 4wd light came on about a week later. They flashed the computer with a new version of the software that fixed the problem. There is a technical bulleting out on flashing the computer to fix the problem. I haven't had the light come on since.
 

·
Registered
Joined
·
506 Posts
My service 4wd light just came on Saturday. I scaned the code u1024 and then took it to the dealer. I had cleared the code and it didn't store it in the history. Anyhow they changed out the dash switch. No problem. These guys are great.
 

·
Registered
Joined
·
89 Posts
Quite often the solder cracks on the circuit board of the dash switch and sets off the service 4wh dr message. resolder the cracks fixes it.
 

·
Registered
Joined
·
563 Posts
had a friend who had the same problem with a 2001. Replaced the 4x4 switch and hasn't had a light in a little over 3 months befroe it would be 2 to 3 times a week. If i recall right it was around 60 dollars
 
1 - 13 of 13 Posts
Top