Diesel Place banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I own a 94 motorhome, diesel pusher GM 6.5 turbo diesel with 4L80E trans. bought it used few months ago. on the drive home would not shift up past 2, after disconnecting the TCM 16196390 and reconnecting shifted perfectly until I had to turn off to fuel up, same thing. came to find out it went into limp mode, I assume. checked all the wires, connections, fuses.., checked with GM found out had the wrong PROM. so I bought another TCM from a running P30 same part numbers. same situation. its been months. local transmission shops don't know and refer me to electricians whom don't know either. I do know the transmission was freshly rebuilt and previous owner replaced the TCM! why? its a mystery as he is no longer with us. but made notes that the TCM thinks its a 6 speed trans and goes crazy and he didn't want to spend money to reprogram.
speaking to another specialist told me to look for a PCM/ECU. this has a mechanical linkage not electronic, I followed the engine harness all the way to the front. nothing that resembles it. the OBD1 connecter is by the TCM above the engine under the bed, mounted to wood frame and not grounded. I even thought the speed sensor or DRAC module could be a problem but the electronic speedometer works fine! please help, I am so frustrated. she's 32' long and wont fit most shops driveway. mobile motorhome tech charged $100 to come and say it's too old nd don't know give me 2007 and up!
 

·
Ronald Reagan fan
Joined
·
4,644 Posts
Welcome to dieselplace.A member here named glagulator will probably step in and help you with this.He’s a wealth of info especially with electrical woes and part numbers,harness problems and wiring diagrams.
 

·
Administrator
Joined
·
19,948 Posts
Welcome to DieselPlace

Can you post the numbers of the PROM currently in use?
What codes are you getting (if any)?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Welcome to DieselPlace

Can you post the numbers of the PROM currently in use?
What codes are you getting (if any)?

the new one off a running 94 P30 with same power train and same TCM has 4104 BJDM 7358 01427389 B9412AD, the thing is I still have the same exact problem. have to reconnect the PCM to shift up, once I stop same problem starts all over. have to pull over disconnect and reconnect. it bothers me also that I can't find a ECU or PCM. someone suggested to flash the system, any ideas?
 

·
Registered
Joined
·
3,685 Posts
You really need to check for trouble codes to find out why the PCM is going into limp mode. There should be codes stored if in limp mode. Unless the PCM is disconnected and cleared.
Drive it until it goes in limp. Then check codes.
 

·
Registered
Joined
·
4,487 Posts
Welcome. Your rig does not have another computer, just the TCM.
Should be a 16196390 TCM. BJDM is correct for your rig.
As said, you should read the codes to see where you are at.
Do you have a check transmission, or check engine light on the
dash that comes on when you first turn the key on, then turns off?
 
  • Like
Reactions: OkDually

·
Registered
Joined
·
155 Posts
Not really a solution and more of a bandaid but what if you just spliced a switch into the 12v power wire / or equivalent going into the TCM. Mount the switch in the cab. When you start the rig toggle the switch to simulate a disconnect/reconnect.
again not a solution but maybe a live-able workaround.
 
1 - 7 of 7 Posts
Top