Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Really difficult to find anyone that knows how to get the cold air intake hose off of the intake heater, appears to have a hard ring around it that may or may not turn and there are no clamps on it. so my question is How do you remove this hose. I can't get to the bolts unless I remove this hose and since I am just replacing the heater, I don't want to break anything that I would have to replace.
Anyone and thanks
 

·
Registered
Joined
·
153 Posts
They can be really sticky. It helps to push the pipe up towards the grid heater and tap that ring with a screwdriver counterclockwise. Don’t break it, but you should be able to feel it go against once it’s far enough. Once it’s twisted far enough, pull out hard, and wiggle the pipe a bit. Should pop off.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
They can be really sticky. It helps to push the pipe up towards the grid heater and tap that ring with a screwdriver counterclockwise. Don’t break it, but you should be able to feel it go against once it’s far enough. Once it’s twisted far enough, pull out hard, and wiggle the pipe a bit. Should pop off.


Sent from my iPhone using Tapatalk
Thanks, it is kind of loose but only moves a very short distance, and won't go any further. I tried to tap it but the screw driver cuts into the little groove How far should it turn?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
You’ve got to pull on it pretty hard to break it loose. Try twisting it the other way, you should be able to feel that it goes a bit further the one way.


Sent from my iPhone using Tapatalk
Thanks for all the info, I did finally get it off, and it appears that ring really doesn't do anything, all I did was kind of pull real hard at an angle and it started to come off of the cone fitting but wow was it scary but once off all went well. I am not sure what changed but it seemed that the truck ran better and got better mileage I went for a 300+ mile trip and per the dic got 20.5, and the 50 mile average for the last 50 was 24.9 and the power was better. I have no idea why. Thanks so much for the info.
 
1 - 5 of 5 Posts
Top