Diesel Place banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I'm fighting an issue with my '07 LMM and have been since 2013 with the drivers seat. Lumbar controls work fine, but any forward, rear, tilt, recline, etc., basically 'bump' meaning the relay clicks, the motor increments about a 1/4 turn and immediately stops. Wait 4-5 seconds and you can 'bump' it again...eventually you can get the seat adjusted, but obviously this takes a lot of time. Here's my situation:

Neither driver nor passenger seat heater will stay on...switch will illuminate for 3 seconds and then will go off.

Passenger power seat controls all function normally.

Memory controls in the door beep and then try to adjust the seat, again 'bump' and stop with regard to the motors. Eventually the seat will find it's adjusted position but only after repeated presses of the button and going through the process one bump at a time with 4-5 second gaps in between. Occasionally...I can get two or three bumps in rapid succession...but usually have to wait the 4-5 seconds.

All of this behaves the same either in Park or in Drive.

I've checked the heated seat elements...none have an open condition. The seat bottom elements test in the 4.5-5 ohm range, and the seat back elements test around 6.7-7ohm. I've read ohm ranges for 2003-2006 are supposed to be below 5, but haven't seen any specs for '07 new style/LMM. Have disconnected and reseated all connectors under both seats as well as the power seat switch controls. Inspected wiring harness for any chafing or breaks...can't find a problem there either. 10A drivers seat dash fuse is good (checked it, but knew it was good...wouldn't even get the 'bumps' if it was open) and have also checked the 60A MBEC Jcase under the hood...also good. 25A breakers above and left of the brake pedal...good. So...unless I've got a bad drivers seat module (wondering if this would also be responsible for the heated seat problem) I don't know what the heck is going on. Have been through this thing as fully as I can.

Let me know if anybody has any good ideas on where to head next with this. I don't want to replace seat elements and then have the same problem...nothing tests shorted or looks burnt at all...clean as a whistle.

Appreciate any help...thanks in advance.
 

·
Registered
Joined
·
16,230 Posts
You ought to have posted this in the interior section instead of the engine section. You might get more help that way. I will see if I can get a mod to move this for you.
 

·
Premium Member
Joined
·
14,363 Posts
Moved. :thumb:
 
1 - 3 of 3 Posts
Top