Diesel Place banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My 2006 express with 6.6 Duramax will start and run but keeps dying
I replaced fuel pressure relief valve with solid race plug
I dropped tank and found a bunch of shmeg in tank including pieces of a rag in the pick up
Cleaned everything out and it started and ran but died again. Any ideas?
 

·
Administrator
Joined
·
15,971 Posts
Welcome to DieselPlace
(y)
 

·
Registered
Joined
·
3,493 Posts
Codes ?
Fuel filters ?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
There was the low fuel rail pressure code when it first started dying while driving but the code cleared and check engine light hasn’t come on again
The filters are a month old or so and look clean
 

·
Registered
Joined
·
412 Posts
Codes? Lift pump running? Filters changed? You should hear fuel coming back to tank while it is. Otherwise hang a small tank to injection pump to see if fuel system is clogged or pressure gauge. Sounds like you have a girl truck and it's her time of the month. Start whispering sweet nothings like "I will always use Power Service additive baby" etc. Sorry if I'm politically incorrect . Sounds like a strange problem because if you had air in system it would be difficult to start but stay running once started.
 

·
Administrator
Joined
·
15,971 Posts
X2^^ check your lift pump and make sure its running
 

·
Registered
Joined
·
3,493 Posts
Filters look clean ? You can only easily see the outer element of the primary filter and I would not go by that. Hook up a gauge at the test port to see how much vacuum you are pulling and that will give you an accurate assessment of what is going on between CP3 and tank.
Since the prime pump only runs with key on engine off it should only have an issue with installing new filters or you run it out of fuel.
Here is a link of one place of where you can find a gauge. Kennedy Diesel
 
  • Like
Reactions: OkDually

·
Registered
Joined
·
4 Posts
Discussion Starter #8
It’s running!!!
I went out this am and pulled the line from pump to motor and turned key on
Ran air for 30 seconds then solid flow! Started and has been running since.
all this because the joker who changed my sending unit a couple years ago left a hand cleaning rag in the tank!!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
Thank you for the help.
I live on Nantucket Island and there’s only a ford dealership out here and nobody knows Duramax
 

·
Administrator
Joined
·
15,971 Posts
Thank you for the help.
I live on Nantucket Island and there’s only a ford dealership out here and nobody knows Duramax
Glad you got the issue resolved.
Thanks for giving us an update!
(y)
 
1 - 10 of 10 Posts
Top