Diesel Place banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Was running fine yesterday had plenty of power no loss of power shut off for couple hours started up to go home and truck didn’t have any power? hit the pedal to the floor just real luggish no power but on edge insight still building boost, checked all intercooler pipes and hoses everything is tight. What could it be? Any help is greatly appreciated
 

·
Administrator
Joined
·
18,984 Posts
Welcome to DieselPlace
any mods to your LLY?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Yes has efi live 5 pos switch, newer stg 2 65mm turbo, wc y bridge, all wc fab Hoses and clamps, cold air intake, built trans could be missing couple more minor things
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
I mean it still idles and sounds fine, and has some power but not no where near as much as before so therefore I know something is not right hoping for something simple
 

·
Administrator
Joined
·
18,984 Posts
I mean it still idles and sounds fine, and has some power but not no where near as much as before so therefore I know something is not right hoping for something simple
Have you checked for any codes?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
No codes
 

·
Administrator
Joined
·
18,984 Posts
Pump the primer button on the filter head till hard and let it sit (preferably overnight) and recheck.
If it is soft then you have an air intrusion/leak that needs to be hunted down
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
On my truck I have looked and looked for the primer head and filter housing but looks like previous owner by passed it and is only using the air dog system for the filtration is that possible?
 

·
Administrator
Joined
·
18,984 Posts
On my truck I have looked and looked for the primer head and filter housing but looks like previous owner by passed it and is only using the air dog system for the filtration is that possible?
It's possible.
Normally the fuel filter head sits on the passenger side of the motor with a large push-button on the top of the head.
filter2.jpg


Connections to/from the airdog could be allowing air to enter
Also start inspecting your engine harness for any rubbed through wire insulation, rodent damage, corrosion, broken wires, etc..
Road vibration and a worn wire can create a short to ground
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
Yeah they must have deleted the stock filter housing and only running air dog.. and where about is the harness that I should be looking for
 

·
Registered
Joined
·
117 Posts
Seeing as you have a lift pump, it's unlikely it's sucking air as the fuel system is now pressurized as opposed to being under vacuum as originally designed. Would be fuel leak if anything.
Check the electrical harness that runs over a bracket above alt, were known to rub thru in that area.
 
1 - 11 of 11 Posts
Top