Diesel Place banner
1 - 14 of 14 Posts

·
Registered
Joined
·
19 Posts
Hello,

Last year I purchased a 1999 GMC 6.5l TD Bluebird school bus, converted it to an RV, got RV plates, insurance, all that, my blog on the conversion is weboughtaschoolbus.blogspot.com if you are interested in seeing that.

Now on to engine issues. I had some stalling happen 3 or 4 times in a 10 mile area, then I got it home, checked the air filters, they are good, started up again fine.

Got oil change, and a new PMD and relocated it to the front bumper. This seemed to fix the issue, but now it continues to stall but only after running for a while, around 10 miles or so and seems to fail after running hot or uphill for a while. Luckily I have some time and space to troubleshoot.

I ordered a new PMD (lots of research lead me to believe it might be that I got a bad one) - a different brand, should come Wed.

So I have some things to try. Like the new PMD.... but anyone know which resistor or if I should have a resistor in there at all? I put the #9, then the #5 and both stalled, I havent tried getting it to stall w/o a resistor, I will try that tomorrow, but wanted to see if anyone had experience in this engine and knew the resistor I should use or if any.

A few notable notes too:
- When it stalls, there is no misfires, it runs great, then it just stalls, losses power steering, etc a few sec later, have to pull over.
- It is hard to start after stalling but I can get it going after a few tries, 5-10 min, the PMD was NOT warm or hot last time I road tested and it stalled.

Other thing I was thinking in troubleshooting was to try to bleed the air out of the fuel line at the engine right away after stalling and see if it starts up immediately, would that let me know its in the fuel lines? Although from what I have read it seems like I would have some misfires or codes or warnings if it were air in the fuel lines.

Anyway, learning as I go, I appreciate the help. Thanks. :thumb:

Mark
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #2 ·
Other info I forgot to mention, the IP was replaced 15K miles ago.... and I also replaced the lift pump which I am sure is working correctly.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #6 ·
Has #5 on now, running it ritht now for 15 min to see if it stalls, then ill drive it around and try the cold water on the IP thing. For what its worh I got the bus from a big wealthy school, so I am pretty sure they used new OEM parts when replacing.

Will let yall know how the tests go, thx for the quick reply!!
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #7 ·
Well it didnt stall after 20 min of idling.... Put some diesel fuel injector cleaner and filled up the tank, drove it around for about 15 min with cold water bottle in hand, no stall... It was busy and i didnt really feel safe "wanting" it to stall so i decided to wait till i have time at a less busy time.

Thx again, any thoughts are appriciated.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #10 ·
Not fixed yet!! : )

Thx Freddyack! I will try that if the new PMD does nothing. Can I leave the clear tubing in afterwards? Also, would it misfire before stalling if it were air? Seems like it does not misfire at any point.

Thx
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #12 ·
Thx, Fuel Filters are in good condition, replaced less than a year ago, are clean - tested lift pump and worked but was very old, so I replaced that last week.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #14 ·
Well that was fun!

Got the new PMD in the mail, got it installed, started up fine, got about half mile down the road and it stalls. Get it going again and it stalls 20 ft later, at a light where people got extremely angry at me while I switched it back to the old one.

Then it runs fine on the old one home.

I thought it was maybe the resistor I put in there since I switched that too, so I put in the other resistor (known good one) in the new PMD and same thing happened, started ok, then died shortly after. Put the old PMD in again, and it runs fine.

So not sure what that tells me, but at least I know this PMD is bad, I am going to try to return it ASAP.

Would there be anything that would be causing the PMD to overheat?

Or is it possible I just have two bad PMDs on my hands, one just much worse than the other?

Thx in advance. In the meantime I am going to try to return this one not exchange and get it from somewhere else, again... :think:
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #17 ·
Luckily I can return it for free through Amazon - I just purchased a different one - D-Tech one, hopefully that one works.

Not sure if this is at least telling me my problem IS the PMD.... but at least the symptoms of a bad PMD are the same symptoms of what I am having happen, what happens to me just takes more driving first.....
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #18 ·
JMJNet - I replaced the LP last week with a new one, works well.... It was night and day when I switched the PMD back to the old one.... so it must be that. Yes relocated with heatsink to front bumper....
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #24 ·
The warranty would make sense. I think they did a lot things as standard as possible since from what I understand they have some rigorous state inspections each year.

I was curious as to what prompted the replacement engine as well....

It was one of the reasons I purchased it though since the engine only has 60k on it, a fairly new IP, so if I can get this stalling bug fixed then I think I got a nice deal at $2500
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #27 ·
New to checking grounds, tried to find a good thread.

I found my main ground that goes to neg on batteries. It doesnt look great, I am guessing you guys will tell me to replace it?

How many other grounds should I check for, I think I saw one coming from the wire harness from the IP?

Thx!
 

Attachments

1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top