Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So I have a ‘13 lml deleted with a FASS lift pump. Recently been having loss of power/dying at low rpms, it showed “engine power derated”, and the p0091 fpr1 voltage low code. So I changed the pressure regulator on the injector pump. No shavings or anything to be concerned about when inspecting the old fpr screen. Put it back together yesterday afternoon. Ran for a second or two then died and hasn’t started since. Am pretty sure it’s not getting fuel. Made sure to prime the fuel system. Found one wire that was rubbing and fixed that. Even tried putting old fpr back in to see if the new one was bad. What am I missing y’all? Thanks!
 

·
Registered
Joined
·
316 Posts
Double check your connections. I won’t say how I know, but the aux alternator, FPR1 and FPR2 all have the same connectors. If they are wrong, it won’t start!
 

·
Registered
Joined
·
158 Posts
Did you get your fuel problem figured out?
 

·
Registered
Joined
·
2,513 Posts
Some people for your code P0091 in this diagram there’s a place where the harness rubs over top the EGR.
https://static.nhtsa.gov/odi/tsbs/2014/SB-10056238-7750.pdf
What are the causes of the P0091 code?
Faulty fuel pump
Faulty fuel pump relay
Faulty PCM
Faulty electric fuel pressure regulator
Restriction in the fuel filter or other parts of the fuel system
Damaged wiring such as a short to ground
Fuel tank low on fuel
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Finally got ahold of a better diagnostic computer and figured out it wasn’t building any fuel pressure. Pretty sure the pump went bad without completely thrashing. Was more of a job than I wanted to tackle so I took it to a mechanic buddy of mine and we will see what he comes up with.
 
1 - 5 of 5 Posts
Top