Diesel Place banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Coming back from the river in my 06 LLY it would lag when I got on the gas, then all of a sudden it would take off like a sling shot (never use to do this). When I got home I turned it off to unload, went to grab dinner and check engine light came on. Scanner is reading code p2563-00 and p003a-00. Which one is the actuator and one is the sensor, do you think they both need to be replaced??
 

·
Administrator
Joined
·
16,738 Posts
Coming back from the river in my 06 LLY it would lag when I got on the gas, then all of a sudden it would take off like a sling shot (never use to do this). When I got home I turned it off to unload, went to grab dinner and check engine light came on. Scanner is reading code p2563-00 and p003a-00. Which one is the actuator and one is the sensor, do you think they both need to be replaced??
Welcome to DieselPlace
I would start by replacing the sensor ( use AC/Delco brand only)
 

·
Registered
Joined
·
3,657 Posts
You can check the vane position sensor by removing it and moving the plunger in out while watching the scanner reading. The most common issue is the vanes are sticking. You could remove the turbo, tear it apart and polish all the hot side moving parts. Put a thin layer of nickel anti-seize on all those parts you just polished and it will be good for a long time. While you have it apart might as well rebuild it.
 
  • Like
Reactions: OkDually
1 - 3 of 3 Posts
Top