Diesel Place banner
1 - 10 of 10 Posts

·
Registered
Joined
·
245 Posts
Discussion Starter · #1 ·
I've got a 06 LBZ cc shorty with almost 11,000 on it. Ive got the edge evo, afe stage 2 and 4in strait pipe on it. When I first got the truck it ran great and got 15-18mpg no problem. I don't drive the truck everyday but throughout the last couple months my milage has been dropping but within the last month or so it has gotten terrible. Empty it runs 9-11mpg and pulling about 8-9. It also seems to have no power especially when it hits 5th gear-I havent seen 6th for quite some time now because it can't do it. When pulling my bobcat it is working real hard at 55 and the egts are real high. Most of the time I have to leave it in 4th gear. To me it seams like it is the turbo that is not working due to the lack of power and high egts. Anyone else hear of anything like this? Any help would be nice, it was embarrassing to have a dodge blow by me today!:mad:
 

·
Registered
Joined
·
144 Posts
I am by no means an expert but from what I've been through and what I've read on here. I would say its the EGR. I had the same problems when my EGR went bad it was stuck open. When it was replaced they also replaced the throttle position sensor ( I think thats what it was). It fixed all my problems. Does your truck smoke alot?
 

·
Registered
Joined
·
11,311 Posts
I would change your fuel filter first before you start to diagnose anything further.
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #5 ·
I took the chip out and brought it into one dealer and the said it was the EGR valve and had no problem fixing it. Then the next day when I brought it in there the other service manager said they wouldn't work on it because of my bigger wheels and tires (305's on 20's), intake and exhaust. Well I could understand the strait pipe exhaust but the other stuff is b.s. So then I brought it to another dealer and they didn't care what I had done to it but they said there was nothing wrong. So now I am in the process of putting the stock intake and exhuast back on for no one can whine at me and I don't burn anymore bridges. Smoke...no the truck doesn't really smoke much at all and never has and I service the truck every 3500 miles and do the fuel filter everyother service.
 

·
Registered
Joined
·
478 Posts

·
Premium Member
Joined
·
1,786 Posts
i agree with 453...before you get carried away i would start with the fuel filter
 

·
Registered
Joined
·
372 Posts
X3...change your fuel filter first....easier than putting all the OEM parts back on.....just one tank of bad fuel can cause alot of problems....I would also put some additive in just in case the fuel was the problem...Power Service or Stanydyne.
 

·
Registered
Joined
·
245 Posts
Discussion Starter · #9 ·
I will try replacing the filter but I still don't believe thats the problem. For the last 3,000 miles or so it has been getting progessively worse and the fuel filter has been changed within that time frame and nothing has changed because I first thought that was the problem to. I have been told by a couple of people to get my boost tested and also it could be the accuator. But I'll still stop and get a fuel filter and try that again?
 

·
Registered
Joined
·
4 Posts
No power

My stock 2006 LBZ developed an oil leak at the turbo resulting in the dealer replacing the turbo. After this the power and mileage declined. The truck has been back to the dealer several times... complaints of power/mileage, trans cooler line leaking, bad ERG, clogged fuel filter, etc. The dealer checked engine codes, "re-flashed" the computer and replaced the fuel filter. They are saying no problems. Still searching for the lost power and poor economy. In addition, more exhaust smoke is apparent.

Any suggestions.
 
1 - 10 of 10 Posts
Top