Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
03 GMC 2500HD LB7

Problem: Lack of acceleration/ lack of power, sometimes will go into a lope idle (like a tractor). If I clear the codes the lope idle will go away.

Codes:
P0103
P0101
P2227
P2228
P0181

What I have replaced:
fuel filter
BAR Sensor
MAF Sensor
Air Filter
Water in the Fuel Sensor

What I think is the problem:
Filter Filter Head Leak? (maybe) I am going to rebuild mine this weekend to see...so wish me luck
 

·
Administrator
Joined
·
18,471 Posts
Welcome to DieselPlace

The fuel filter heads are a known problem source. Rebuild or replace. If you rebuild be sure to find a kit that includes a metal bleed screw. The plastic screws tend to crack and allow air to enter the fuel system.

Inspect every inch of your engine harness. The Duramax wire harness is known for rubbed through wire insulation issues.
Look for any rodent damage, corrosion, broken wires, etc..
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thank you for the welcome!

I did the rebuild on the fuel filter head and I got the one with the metal bleeder screw. I also replaced the fuel hoses that are connected to it. They were pretty dried up and were tough to get off.

It still has the engine light on, same symptoms, and codes. I also cleared the codes after completing the job. I will continue looking through the wire harness.

Thank you for the tips. I joined this group bc facebook pages were getting me nowhere..."just google it" like I haven't done the research before asking.
 

·
Administrator
Joined
·
18,471 Posts
Thank you for the welcome!

I did the rebuild on the fuel filter head and I got the one with the metal bleeder screw. I also replaced the fuel hoses that are connected to it. They were pretty dried up and were tough to get off.

It still has the engine light on, same symptoms, and codes. I also cleared the codes after completing the job. I will continue looking through the wire harness.

Thank you for the tips. I joined this group bc facebook pages were getting me nowhere..."just google it" like I haven't done the research before asking.
The "Tractor Mode" or loping is an indicator of a wire harness issue.
When you replaced these sensors:
fuel filter
BAR Sensor
MAF Sensor
Air Filter
Water in the Fuel Sensor

did you use AC/Delco parts or aftermarket??
 

·
Registered
Joined
·
3 Posts
Bob,
Wondering if you ever figured out your problem. I had similar symptoms on my Cal emissions LB7. I replaced boost pressure sensor, EGR vacume solenoid, and the EGR valve and everything went back to normal. EGR valve had a hole in the diaphragm causing the truck to boost low and the valve to work erratic.
 
1 - 5 of 5 Posts
Top