Diesel Place banner

1 - 13 of 13 Posts

·
Registered
Joined
·
488 Posts
Discussion Starter · #1 ·
Bought the dmax in October, put on about 3k miles so far.
Have basically babied it, never over 3/4 throttle and it seemed like it might have some power lurking in the bowels but today I found out its all show and no go.
Driving home from work @65 mph on 4 lane coming up on a car at a reasonable rate but not too fast in preparation to pass when I noticed this woman coming up on me in right lane in a big hurry and I could just tell she was going to cut me off at the pass so to speak and cut between the car in front and me.
Having this big idea that I could stop that maneuver by speeding up a tad and blocking the door I stepped on it and to my surprise it didn't do a dam thing, it just did not want to accelerate.
Needless to say she got a kill there and I got squat, I can't believe how flat this truck is above 65mph, Crap, a Geo Metro could blow my doors off
my ol 80 with the 6.5TD will eat this thing alive maybe not until above 60 but from there on it would be no contest old Blue would smoke the max.
Needless to say I am a little upset with the situation here, the truck doesn't miss a beat, it seems to have power until cruising speed and on cruise control.
Truck has had injectors replaced 10k ago along with fuel pressure regulator, scan gauge says no codes, fuel filter replaced under recall and a JK Mega filter installed about 2k ago, its weird to be going along at 65mph and give it some throttle and nothing happens, I can just play with throttle from half to just under full throttle and it doesn't do squat, it accelerates like a snail.
What in the world is the matter here?, it is ok in lower gears but just after 5th gear tcc lock it is just out to lunch.
Any thoughts ??? HELP!!!
Merle
Please excuse the long post, but extreme frustration reigns here.
 

·
Registered
Joined
·
138 Posts
Could be a number of things. I'm not an expert by any means, but here are my KISS ideas....

Try easing into full throttle instead of mashing the pedal to the floor....
Poor air flow, clogged filter?
The fuel flow should be ok with the lack of miles on your filters...
Could the accelerator position sensor have a flat spot?

I'm sure the other guys have some good ideas, but something isn't right there.
My '01 pulls hard when i hit the pedal at highway speeds.

Good luck!
 

·
Registered
Joined
·
12,262 Posts
It's all ECM TCM torque management.Did it downshift and just lay there? Ease up on the throttle, let it up shift and she'll take off.

Turn the wick up and upgrade your tranny and you wont be killed.
 

·
Registered
Joined
·
488 Posts
Discussion Starter · #4 ·
I never went to full throttle ,close, but not enough for a downshift and it just basicly flipped me off.
Edge EZ coming next week and if that don't ignite the dog its either something more radical or a trip to Holland Mi in its future.
Merle
 

·
Registered
Joined
·
212 Posts
My 01 will skit and get when I push the throttle down at 65, it will down shift and it will get up to 90 before you even realize it. It is pure stock and has the same response with a 22 foot boat behind it. So you have something wrong. Don't have any idea what it is but I would get it to the stealler and have them take a look at it.
 

·
Registered
Joined
·
2,472 Posts
My 01 even before the power mods when i would give it enoght to no downshift but just at tha point it pulls really good in 5th for me. Now once i get my tranny done and a 160hp tune then lookout
 

·
Registered
Joined
·
225 Posts
Mine jumps right up from 65 to 80. I stop people from passing me all the time. Since your experience is different, it might be a sign that something is out of whack. Hope everything's okay, though.
 

·
Vendor
Joined
·
9,676 Posts
A little bit of fuel from the Edge and a little bit of flow from a good exhaust system will make a world of difference...
 

·
Registered
Joined
·
681 Posts
I've experienced this from time to time. Usually when I'm pulling out to pass someone on a two-lane. Sometimes the thing is a total rocket ship and sometimes it falls on its face. The rate of throttle input is what seems to do it. If I just floor it the response isn't as good -- better to roll into it just a little and give the tranny an extra split second to unlock the TC or downshift depending on what speed you're traveling. Like Mackin said, it's probably torque management functions of the ECM and TCM.
 

·
Registered
Joined
·
488 Posts
Discussion Starter · #10 ·
Food for thought, this morning on the way to work I played with it a bit and was surprised at what I found.
When driving with cruise control engaged it does not want to accept any throttle overide, with cruise off it is better but my 6.5 would still wax it above 65.
Merle
 

·
Registered
Joined
·
681 Posts
Yeah, you have to push the pedal down a long way before it'll override cruise. Maybe that was part of the problem the other day?
 

·
Registered
Joined
·
1,048 Posts
A stock truck is not a hot rod, but my 02 would surprise the devil out of me before it got the Edge. 65-90 in just a little bit. John Kennedy put it best ... let her breath - then feed her fuel - - - then HANG ON!
 

·
Registered
Joined
·
144 Posts
My 03 is all stock, but its quite capable of getting up and going, even at 70-75. And even when pulling a heavy horse trailer. After an overly easy pass at 80 or so I like to tell my wife, "That guy just got Duramaxed". Sounds like you got a problem. I'd sure look into it before Juicing it. You might just be covering up an impending major issue.
 
1 - 13 of 13 Posts
Top