Diesel Place banner
1 - 12 of 12 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
I’m back again. I married two ‘97 K3500s to get a running farm truck. The engine in the 2nd had 235K miles but started almost instantly, probably a 3 second crank, without hesitation every time until a couple of weeks ago. But prior to that, I did have it die while driving once and it happened right when I flipped on the headlights so I thought it may just have been a battery issue. The Service light has popped on and stayed on 4 or 5 times, but my scanner from harbor freight won’t connect on this truck. It did with the old truck. It powers on and tries, but has some communication failure. After starting and driving the truck A few times the Service light will disappear.

Then the hard starting started. It would crank and crank with fully charged batteries (less than 2 years old) for several seconds and nothing. I do not wait the recommended minute to let the starter cool, but run a second cycle of the glow plugs and do it again. If I pump the accelerator pedal it seemed to help getting it started. It would usually start on that second try with a fairly long crank again. I try to never go past a 10 second crank cycle. If it wouldn’t start on 3 attempts I would let it sit and try later, I was always able to get it started eventually. Even if I had driven it for a while so the engine was good and warm, it might not start right back up, right after shutting it off.

Once I got it running, it worked basically as always, but occasionally I would feel that split second miss that sounds like that “fish biting” as posted here. This could happen while idling or while driving, but was not consistent. I swapped out 2 different PMDs and got the exact same hard start, so I went back to the one I’ve been using on the truck all along. Then the last day I used the truck, I started it four times and it fired right up within those 3 seconds just like before. Head scratching now?
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #3 ·
I’ll try the next time the Service light pops on. I was thinking my code reader was ok because it still works on my other cars.
 

·
Administrator
Joined
·
22,295 Posts
The fish biting is usually electrical related. Inspect every inch of your engine harness for any worn wire insulation, rodent damage, loose connectors, loose or bent pins in the connector.
Also, inspect the PMD harness
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #5 ·
Do you mean the extension pmd harness, or the one that goes down to the IP? I put 2 different extension harnesses on it, one was basically brand new, and they didn’t have any affect. Does the one that comes from the IP have a connector at it or is it hard wired?
 

·
Administrator
Joined
·
22,295 Posts
Do you mean the extension pmd harness, or the one that goes down to the IP? I put 2 different extension harnesses on it, one was basically brand new, and they didn’t have any affect. Does the one that comes from the IP have a connector at it or is it hard wired?
The engine harness. Then the PMD extension harness and inspect the OEM PMD harness wire with caution ( it will damage easily at the fuel solenoid )
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #8 ·
So, when I went to start it this morning and smoke came out from under the hood on passenger side during the wait to start cycle. I shut it off and popped the hood and cycled it again. Smoke again came up from the passenger side back by the firewall but down in the bay. It’s just me so I couldn’t flip switch on and get around in time to tell, but I could hear it crackling too. The engine fired right up after the glow plug cycle each time , but I definitely have to fix this. I pulled the right front wheel, but that didn’t really help. This engine has oil all over back there so I tried to clean it with brake clean at first and then engine degreaser and water from my pump up sprayer. They didn’t do much. I could see the back glow plug connector which was saturated with oil, but didn’t look like smoke had come from there. I’m guessing it or harness for the glow plugs there though? Could this be part of my sporadic hard starting?
 

·
Administrator
Joined
·
22,295 Posts
So, when I went to start it this morning and smoke came out from under the hood on passenger side during the wait to start cycle. I shut it off and popped the hood and cycled it again. Smoke again came up from the passenger side back by the firewall but down in the bay. It’s just me so I couldn’t flip switch on and get around in time to tell, but I could hear it crackling too. The engine fired right up after the glow plug cycle each time , but I definitely have to fix this. I pulled the right front wheel, but that didn’t really help. This engine has oil all over back there so I tried to clean it with brake clean at first and then engine degreaser and water from my pump up sprayer. They didn’t do much. I could see the back glow plug connector which was saturated with oil, but didn’t look like smoke had come from there. I’m guessing it or harness for the glow plugs there though? Could this be part of my sporadic hard starting?
The glow plug harness for the passenger side bank runs from the controller, down the bell housing, and beside the starter shield to each cylinder.
It's not too complicated to remove and replace that harness.

I would pull the complete harness and inspect it, make any repairs and/or replace it if needed
 

·
Administrator
Joined
·
22,295 Posts
You would get the most access to that side if you remove the tire and wheel well liner.
Should be about 13 nuts/bolts
 

·
Registered
Joined
·
4,018 Posts
If your scanner works ok in other vehicles but not your truck. Non communication means with the PCM means You may have problems with the wiring and grounds.
The electrical system burning up when starting kind of confirms a major wiring problem. You should inspect the complete system. Especially All the grounds, power connections, fuses ect. The Scanner gets power from the cig lighter fuse, check that also.
 
  • Like
Reactions: OkDually
1 - 12 of 12 Posts
Top