Diesel Place : Chevrolet and GMC Diesel Truck Forums - View Single Post - Odd issue..
Thread: Odd issue..
View Single Post
Old 03-07-2016, 10:21 PM   #30 (permalink)
OkDually
Administrator
 
OkDually's Avatar
 
Join Date: Jul 2013
Location: N.E. Oklahoma
Posts: 13,855

Quote:
Originally Posted by Towers91 View Post
Soo... It did it again, it ran fine after a fuel filter change, and lift pump change, it ran fine since my last post until tonight, i let it idle to warm it up and it died, still gets fuel to the filter
What was the condition of the inside,bottom of the fuel filter canister?

If it is dirty it is recommended you clean it.
What was the condition of the screen manager down inside of the bottom of the fuel canister??

The small screen manager is always forgotten about and can cause issues.

Here is a video of how to remove and replace the screen manager.
https://www.dieselplace.com/forum/63-...ml#post7520401

It sounds like your still getting air in your fuel system as well

__________________
1996 K3500 6.5L,( "F" Eng #141 cast block) 5 speed manual, crewcab, dually longbed: 208,000mi.
Diamond Eye 4" Turbo Back Exhaust w/2.5" Flo-Pro Crossover
AirDog II DF165 w/ tank sock delete - XDP
TD-Max boost controller - Kennedy Diesel
OPS extension hose - Leroy Diesel
Glow Plug Harness- PT Wiring Solutions
Glowshift Maxtow EGT,Boost, Fuel gauges
Boost & Fuel Pressure Bolts - Leroy Diesel
2/0 Battery Cable Upgrade - PT Wiring Solutions
PMD w/#9 resistor and Re-Location Kit, mounted to bumper - Leroy Diesel
GM-5 Turbocharger
4.10 gear ratio
OptiLube summer + Formula


Proud member #1039 of The 3500 Dually Club

Offline   Reply With Quote